Bug 840720 - Family dropdown in executed tasks form is not sorted
Family dropdown in executed tasks form is not sorted
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
low Severity unspecified (vote)
: 0.9.2
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 00:38 EDT by Dan Callaghan
Modified: 2012-08-09 04:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-07-17 00:38:56 EDT
Should probably be sorted alphabetically. We should also omit families which have no valid distro trees any more. Use the same code as the family dropdown box in new reserve workflow.
Comment 1 Bill Peck 2012-07-17 15:35:44 EDT
(In reply to comment #0)
> Should probably be sorted alphabetically. We should also omit families which
> have no valid distro trees any more. Use the same code as the family
> dropdown box in new reserve workflow.

I don't think we want to exclude distro trees that aren't valid anymore because that is still valid data.
Comment 2 Dan Callaghan 2012-07-17 18:52:57 EDT
(In reply to comment #1)

Good point. Maybe we can exclude distro families that have never run though. I'm trying to think of a way to exclude the junk like "STABLE" and "RedHatEnterpriseLinux66" etc.
Comment 4 Dan Callaghan 2012-07-19 21:07:47 EDT
On Gerrit: http://gerrit.beaker-project.org/1229
Comment 5 Dan Callaghan 2012-08-09 04:06:56 EDT
Beaker 0.9.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.