Bug 840746 - BETA 2 - expose NetworkOperationsConnectivityTimeout in rhevm-config
BETA 2 - expose NetworkOperationsConnectivityTimeout in rhevm-config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.1.0
Assigned To: Moti Asayag
Meni Yakove
network
: Improvement
: 820879 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 03:07 EDT by lpeer
Modified: 2016-02-10 14:49 EST (History)
11 users (show)

See Also:
Fixed In Version: si14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lpeer 2012-07-17 03:07:11 EDT
Description of problem:

When checking connectivity the user should be able to specify the time-out.
This field is missing from setup networks dialog.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lpeer 2012-07-17 03:53:22 EDT
*** Bug 820879 has been marked as a duplicate of this bug. ***
Comment 4 Simon Grinberg 2012-07-17 13:07:18 EDT
I recall something about complaints that it was too long.

But for setup networks it is critical since we do it when the host is not in maintenance. What will happen if this time is longer then the response timeout? Will the host be fenced? In any case I don't think it should be in the dialogue, but as a rhevm-config parameter.

I recall that VDSM did the roll back, so does VSDM supports that on the API?
Comment 5 lpeer 2012-07-18 02:56:05 EDT
(In reply to comment #4)
> I recall something about complaints that it was too long.
> 
> But for setup networks it is critical since we do it when the host is not in
> maintenance. What will happen if this time is longer then the response
> timeout? Will the host be fenced? In any case I don't think it should be in
> the dialogue, but as a rhevm-config parameter.
 
after 3 minutes of not having connectivity to the host, we get a timeout and the host is moved to non-responsive, the regular non-responsive treatment is used.

So we don't need to set timeout in the dialog?

We already have it in config but this is not editable by the user.
We can change this to be available for the users instead of having it in the dialog.

simon please approve.
Comment 6 Simon Grinberg 2012-07-18 10:41:17 EDT
> after 3 minutes of not having connectivity to the host, we get a timeout and
> the host is moved to non-responsive, the regular non-responsive treatment is
> used.

That is not good enough, we need VDSM roll back, not a fencing treatment. Is there a VDSM rollback on loss of connectivity? 

Logic should not change in the engine, if VDSM does fail to roll back then indeed engine should go for non-responsive treatment.

Note that this means that the rollback timeout must be less then the fencing trigger - you don't want to get into races here.    

> 
> So we don't need to set timeout in the dialog?
> 
> We already have it in config but this is not editable by the user.
> We can change this to be available for the users instead of having it in the
> dialog.

Yes, let's make it configurable by the user, I don't see it necessary to have this parameter editable per setupNetworks operation. 
>
Comment 7 lpeer 2012-07-19 02:57:19 EDT
After a discussion with Simon we agreed to add this as a config parameter available for the user but not on the UI dialogs.
Comment 10 Moti Asayag 2012-08-08 12:00:09 EDT
A suggested patch:

http://gerrit.ovirt.org/7006
Comment 13 Meni Yakove 2012-08-16 02:59:22 EDT
Tested on rhevm-3.1.0-12.el6ev.noarch, vdsm-4.9.6-28.0.el6_3.x86_64.

Note You need to log in before you can comment on or make changes to this bug.