Bug 840866 - [rhevm-dwh] - History DB - View v3_1_host_hourly_history_view shows 61 minutes instead of 60 minutes (Column minutes_in_status)
[rhevm-dwh] - History DB - View v3_1_host_hourly_history_view shows 61 minute...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Yaniv Lavi
David Botzer
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 08:35 EDT by David Botzer
Modified: 2016-02-10 14:12 EST (History)
9 users (show)

See Also:
Fixed In Version: si22 - rhevm-dwh-3.1.0-16.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, the host hourly history view in the database began counting minutes at 1. The hour finished at 61 minutes. Minute counting was changed to begin at 0, so that each hour finishes at the 60th minute.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:20:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
61min (60.81 KB, image/png)
2012-07-17 08:35 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2012-07-17 08:35:44 EDT
Created attachment 598625 [details]
61min

Description of problem:
View v3_1_host_hourly_history_view minutes_in_status shows 61min whereas in an hour there is only 60min

Version-Release number of selected component (if applicable):
3.1/si10

How reproducible:
always

Steps to Reproduce:
1.install rhevm+dwh
2.wait for an hour
3.examine the View v3_1_host_hourly_history_view
  
Actual results:
shows in column minutes_in_status 61min

Expected results:
Should show in column minutes_in_status 60min

Additional info:
pic
Comment 1 Yaniv Lavi 2012-10-18 12:29:31 EDT
Fixed upstream:
http://gerrit.ovirt.org/#/c/8634/

and downstream;
https://gerrit.eng.lab.tlv.redhat.com/#/c/2731/



Yaniv
Comment 3 David Botzer 2012-10-28 08:52:52 EDT
Fixed, 3.1/si22.1
Works correctly, shows 60 min starting xx:00 - xx:59
Fixed, 3.1/si22.1
Comment 5 errata-xmlrpc 2012-12-04 13:20:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1534.html

Note You need to log in before you can comment on or make changes to this bug.