Bug 840933 - Do not submit multiple jobs referring to the same VM image (KVM)
Do not submit multiple jobs referring to the same VM image (KVM)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Release_Notes (Show other bugs)
2.2
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Capek
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 12:23 EDT by Luigi Toscano
Modified: 2012-09-20 08:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
When multiple VM universe jobs refer to the same VM image, they are not prevented from using the image at the same time in KVM. Multiple jobs, represented by qemu-kvm processes, accessing the same VM image can cause data corruption. To work around this bug, do not submit multiple jobs referring to the same VM image.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 08:37:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Toscano 2012-07-17 12:23:48 EDT
Description of problem:
The problem is described into rhbz839961: when multiple VM universe jobs refer to the same VM image, they are not prevented to using it at the same time in KVM. Multiple jobs (i.e. multiple qemu-kvm processes) accessing the same VM image can easily lead to data corruption.
The issue is not scheduled for inclusion in the next version of MRG (2.2), hence the request for inclusion into release notes (even if it is not a regression).

Note You need to log in before you can comment on or make changes to this bug.