Bug 841050 - Updating from RHEL 6.2 to 6.3 overwrites KSM config files without warning
Updating from RHEL 6.2 to 6.3 overwrites KSM config files without warning
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 21:21 EDT by David Kovalsky
Modified: 2014-07-01 08:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 09:34:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-07-17 21:21:04 EDT
I've upgraded a KVM host machine from 6.2 to 6.3 and come to notice that /etc/sysconfig/ksm and /etc/ksmtuned.conf were back at their defaults.

No warning, no .rpmnew/.rpmold files creaed. 


Overwriting root config files is bad from user PoV, KSM config files should be marked as %config(noreplace)


qemu-kvm-0.12.1.2-2.295.el6.x86_64
Comment 1 Suqin Huang 2012-07-18 22:14:20 EDT
Hi David,

I don't think this is qemu-kvm bug, change component to kernel.

Thanks
Suqin
Comment 2 David Kovalsky 2012-07-19 05:38:35 EDT
I believe it is qemu-kvm, RPM thinks the same :)

# rpm -qf /etc/ksmtuned.conf
qemu-kvm-0.12.1.2-2.295.el6.x86_64

# rpm -qf /etc/sysconfig/ksm 
qemu-kvm-0.12.1.2-2.295.el6.x86_64


To be clear, I haven't checked the specfile, but I believe this is a packaging bug in qemu-kvm specfile.
Comment 3 Ademar Reis 2012-07-27 10:03:41 EDT
I checked the .spec file and both files are marked %config(noreplace) there since the package was imported into RHEL6, so this shouldn't happen.

Can someone from QE please try to reproduce it?

Testcase is simple:
 - install RHEL6.2
 - change something in the /etc/ksmtuned.conf and /etc/sysconfig/ksm files
 - upgrade to RHEL6.3
 - check if the files have been ovewritten and there are no .rpmsave or .rpmnew files

Maybe it's an installer bug?
Comment 4 Suqin Huang 2012-08-08 01:25:00 EDT
Hi Devid,
I can not reproduce this bug.

1). edit /etc/ksmtuned.conf and /etc/sysconfig/ksm
2). update qemu-kvm-0.12.1.2-2.209.el6.x86_64 to qemu-kvm-0.12.1.2-2.295.el6.x86_64
    or update all packages from rhel6.2 to rhel6.3

result:
ksmtuned.conf and ksm is not overwritten, it keep the same as the one before update.

if I remove old qemu-kvm and install new one, .rpmsave will be created
Comment 5 Ademar Reis 2012-08-08 09:34:58 EDT
- both files are marked %config(noreplace)
- QE couldn't reproduce it

If you reproduce it, please reopen this bug and let us know how to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.