Bug 841061 - the src spice client show black screen before migration finish
the src spice client show black screen before migration finish
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.9
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: David Blechter
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 22:30 EDT by langfang
Modified: 2013-01-09 20:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 02:45:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
before migration finish ,the src spice client result (6.52 KB, image/png)
2012-07-17 22:39 EDT, langfang
no flags Details
src (18.85 KB, text/plain)
2012-07-18 23:07 EDT, langfang
no flags Details
destination (1.79 KB, text/plain)
2012-07-18 23:10 EDT, langfang
no flags Details
spice (4.59 KB, text/plain)
2012-07-18 23:11 EDT, langfang
no flags Details

  None (edit)
Description langfang 2012-07-17 22:30:56 EDT
Description of problem:
boot guest with spice,then do migration -->the src spice client cut off(before migration finish)-->open src spice client again--->show black screen

Version-Release number of selected component (if applicable):
host:rhel5.9

# uname -r
2.6.18-327.el5

# rpm -q  kvm
kvm-83-256.el5

# rpm -q spice-client
spice-client-0.8.1-6.el5_8.2

How reproducible:

100%
Steps to Reproduce:
1.boot guest with spice
 /usr/libexec/qemu-kvm -m 4G -smp 4 -usbdevice tablet -drive file=/mnt/rhel5.8-test2.qcow2,if=virtio,boot=on,werror=stop,cache=none,format=qcow2,media=disk -net nic,macaddr=4a:22:15:26:29:31,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid d06e43e7-d27a-4b04-b99a-d30d898ca64f -cdrom /mnt/RHEL5.8-Server-20120202.0-x86_64-DVD.iso -boot d -monitor stdio -spice host=0,ic=on,port=2000,disable-ticketing -qxl 1

2.boot guest 
....-incoming tcp:0:5999

3.(qemu)migrate -d tcp:0:5999
Migration status: active
transferred ram: 13311 kbytes
remaining ram: 2591912 kbytes
total ram: 4280408 kbytes

   
Actual results:
#spicec -h 10.66.4.183 -p 2000
connect : Connection refused
Warning: abort

open the src spice client again-->show block screen


Expected results:
before migrate finish,the src spice client should work normally.

Additional info:
1)after migrate finish.the src spice client is normal ,can see the screen again
2)test this with windown2008,also have the same problem
3)use vnc to test the src client work well.

do the same test on rhel6.3 host ,not hit the issue.the src spice client work well.
Comment 1 langfang 2012-07-17 22:39:07 EDT
Created attachment 598774 [details]
before migration finish ,the src spice client result
Comment 3 RHEL Product and Program Management 2012-07-17 23:08:13 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Yonit Halperin 2012-07-18 11:09:19 EDT
Hi,
you mean that the client is closed everytime migration occurs?

Please provide the qemu logs for both the migration src and the migration destination. Also provide the spice client log (under ~/.spicec/spicec.log).

The destination is rhel5 as well?

The issue to be investigated here is the client being disconnected from the src.
The black screen upon reconnection to the src during migration is not surprising, since in Rhel5 spice blocks new connection once migration has started.

Thanks,
Yonit.
Comment 6 langfang 2012-07-18 23:03:02 EDT
(In reply to comment #5)
> Hi,
> you mean that the client is closed everytime migration occurs?

yes

> Please provide the qemu logs for both the migration src and the migration
> destination. Also provide the spice client log (under ~/.spicec/spicec.log).
> 
> The destination is rhel5 as well?

yes,do the local migration
 
> The issue to be investigated here is the client being disconnected from the
> src.
> The black screen upon reconnection to the src during migration is not
> surprising, since in Rhel5 spice blocks new connection once migration has
> started.

Yonit, follow  above description,this is a normal phenomenon,right?thanks
> Thanks,
> Yonit.
hi! Yonit
  the src qemu log please see attachment: src.log
  the des qemu log please see attachment:des.log
  the spicec log please see spicec.log
Comment 7 langfang 2012-07-18 23:07:41 EDT
Created attachment 599047 [details]
src
Comment 8 langfang 2012-07-18 23:10:36 EDT
Created attachment 599048 [details]
destination
Comment 9 langfang 2012-07-18 23:11:20 EDT
Created attachment 599049 [details]
spice
Comment 10 Yonit Halperin 2012-07-19 02:16:54 EDT
Hi,
I think your migration cmd line is incomplete. In rhel5, in order to include spice in the migration, the cmd line should be:
migrate -d tcp:<dst-host>:<dst-port>,spiceport=<dst-spice-port>,spicehost=<dst-host>
Please let me know if now it works.
Comment 11 langfang 2012-07-19 02:38:52 EDT
hi!Yonit
   you are right.use cmd line "migrate -d tcp:<dst-host>:<dst-port>,spiceport=<dst-spice-port>,spicehost=<dst-host>",it work now.not  show dark screen.thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.