Bug 841074 - Failed automatic update
Failed automatic update
Status: CLOSED DUPLICATE of bug 838053
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 00:45 EDT by Gabriel Torres
Modified: 2014-01-21 18:23 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 16:44:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Torres 2012-07-18 00:45:21 EDT
Description of problem:
ERROR with transaction check vs depsolve:
libcups.so.2 is needed by gtk2-2.24.10-2.fc17.i686
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-3.fc17.i686

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Update
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 james 2012-08-08 08:31:03 EDT
I get this message during Updating of Fedora 17

ERROR with transaction check vs depsolve:
/usr/bin/db_stat is needed by rpm-4.9.1.3-7.fc17.x86_64
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-3.fc17.i686
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
Comment 2 james 2012-08-09 07:55:40 EDT
Solution :

su 
password

then 

yum clean all
rpm --rebuilddb
yum update 

Refer this link http://www.reddit.com/r/Fedora/comments/wz3xn/upgrade_almost_not_broken/
Comment 3 Piotr Madanecki 2012-09-13 14:26:35 EDT
To fix "/usr/bin/db_stat is needed by rpm-4.9.1.3-7.fc17.x86_64" error:

yum install libdb-utils
yum update
Comment 4 James Antill 2013-05-28 16:44:19 EDT

*** This bug has been marked as a duplicate of bug 838053 ***

Note You need to log in before you can comment on or make changes to this bug.