Bug 841086 - Tomcat6 runs as unconfined_java_t
Tomcat6 runs as unconfined_java_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.2
All Linux
high Severity high
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 02:28 EDT by William Brown
Modified: 2014-10-14 03:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:56:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Brown 2012-07-18 02:28:30 EDT
Description of problem:
Tomcat6 should run in a confined tomcat domain. At this time it runs as unconfined_java_t.

Version-Release number of selected component (if applicable):
tomcat 6.0.24
EL 6.2

How reproducible:
Always

Steps to Reproduce:
1. yum install tomcat6
2. service tomcat6 start
  
Actual results:
ps auxZ | grep tomcat

unconfined_u:system_r:unconfined_java_t:s0 tomcat 


Expected results:
Tomcat should run in a confined domain

Additional info:
This may be related to https://bugzilla.redhat.com/show_bug.cgi?id=837149
Comment 2 RHEL Product and Program Management 2012-12-14 03:41:22 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2014-10-14 03:56:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html

Note You need to log in before you can comment on or make changes to this bug.