Bug 841123 - GLIBC problem when running febootstrap
GLIBC problem when running febootstrap
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: febootstrap (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: Reopened
: 841141 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 04:30 EDT by fd.intech
Modified: 2012-07-24 05:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 07:39:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
febootstrap command output (99.95 KB, application/octet-stream)
2012-07-18 04:30 EDT, fd.intech
no flags Details

  None (edit)
Description fd.intech 2012-07-18 04:30:00 EDT
Created attachment 598815 [details]
febootstrap command output

Description of problem:
I need to create a chrooted sandbox to be able to simulate some commands. At the end of sandbox creation using febootstrap, bash outputs some relocation errors about GLIBC.

Version-Release number of selected component (if applicable):
febootstrap-3.12-1.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Run `febootstrap fedora-17 /home/intech/livraisons/sandbox-test`
  
Actual results:
See attached file.

Expected results:
The same as attached file without three last lines, that is to say:
/bin/bash: relocation error: /home/intech/livraisons/sandbox-test/usr/lib64/libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: relocation error: /home/intech/livraisons/sandbox-test/usr/lib64/libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
rm: relocation error: /home/intech/livraisons/sandbox-test/usr/lib64/libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference

Additional info:
Comment 2 Richard W.M. Jones 2012-07-18 05:08:29 EDT
We don't support using febootstrap-2.x to create sandboxes, and it's
not likely to work, and febootstrap 2 is obsolete anyway.

Use this instead:

sudo yum --installroot=...
Comment 3 Richard W.M. Jones 2012-07-18 05:09:13 EDT
*** Bug 841141 has been marked as a duplicate of this bug. ***
Comment 4 fd.intech 2012-07-18 06:46:28 EDT
Why are you talking about febootstrap 2? I am using febootstrap-3.12-1.el6.x86_64.
Comment 5 Richard W.M. Jones 2012-07-18 07:39:01 EDT
That package includes the old, unsupported febootstrap-2.x
scripts as 'febootstrap' etc. (the new febootstrap programs
are called 'febootstrap3' etc.).  Please follow the suggestion
I made in comment 2, and don't reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.