Bug 84116 - db4 need a patch to compile Python bindings
db4 need a patch to compile Python bindings
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: db4 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-12 09:19 EST by Need Real Name
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-13 23:15:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
db-4014-patch.txt (910 bytes, patch)
2003-02-12 09:19 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2003-02-12 09:19:11 EST
The db-4014-patch.txt from bsddb3-4.1.3 distribution is needed to compile python
binding correctly (successful python test.py).

Without this patch, some useful software like Straw (the GNOME 2 Desktop news
aggregator http://www.nongnu.org/straw) can't work because of the python binding
requirement.

After a rebuild of db4-4.0.14-20.src.rpm with this patch, I successfully build
bsddb3-4.1.3 and launch the news aggregator.

Please apply this small patch.

TIA
Comment 1 Need Real Name 2003-02-12 09:19:59 EST
Created attachment 90032 [details]
db-4014-patch.txt
Comment 2 Need Real Name 2003-02-12 09:26:14 EST
Additionaly to this, but related to Straw itself, I need to rebuild pygtk2 with
./configure --enable-thread to be able to launch Straw.

So my question: is it possible to modify your pygtk2 package to add this
autoconf option?
Comment 3 Jeff Johnson 2004-11-13 23:15:57 EST
bsddb is now integrated with python, and there have been
several releases of Berkeley DB since 4.0.14, so presumably
the patch (or equivalent) has already been incorprorated.

If that is not the case, please reopen the bug and reassign
to pygtk2 so that I can get confirmation whether a change
to Berkely DB is actually needed.

Note You need to log in before you can comment on or make changes to this bug.