Bug 841184 - Got traceback while SLA subscription (37060.pem) subscribe for 8 cpu socket machine.
Got traceback while SLA subscription (37060.pem) subscribe for 8 cpu socket m...
Status: CLOSED DUPLICATE of bug 840637
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-18 07:22 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 14:00:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error screenshot (22.02 KB, image/png)
2012-07-18 07:22 EDT, spandey
no flags Details

  None (edit)
Description spandey 2012-07-18 07:22:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Prerequisites : 
subscription-manager-migration-1.0.9-1.git.22.35b5155.el5
subscription-manager-1.0.9-1.git.22.35b5155.el5
subscription-manager-gui-1.0.9-1.git.22.35b5155.el5
subscription-manager-firstboot-1.0.9-1.git.22.35b5155.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5

[root@localhost ~]# subscription-manager facts --list
cpu.core(s)_per_socket: 1
cpu.cpu(s): 1
cpu.cpu_socket(s): 8
distribution.id: Tikanga

[root@localhost ~]# ls /etc/pki/product/
37060.pem

Steps to repro : 
Register client to candlepin using Subscription-manager gui .
Select Admin owner from list and press next.

Expected Result :


Actual Result : 
Never ending process started for finding suitable service level , got following trace back on client console  

Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 971, in _watch_thread
    callback(retval)
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 515, in _on_get_service_levels_cb
    "this system."), parent=self.parent_window)
AttributeError: 'SelectSLAScreen' object has no attribute 'parent_window'
Comment 1 spandey 2012-07-18 07:22:56 EDT
Created attachment 598855 [details]
error screenshot
Comment 2 Adrian Likins 2012-07-19 14:00:50 EDT
commit 93c65c65ef65429945b4e4e24b9545ac784f0037
Author: Michael Stead <mstead@redhat.com>
Date:   Mon Jul 16 16:10:07 2012 -0300

    840637: Fixed missing reference to parent window.


Should fix that.

*** This bug has been marked as a duplicate of bug 840637 ***

Note You need to log in before you can comment on or make changes to this bug.