Bug 841193 - [admin-portal] direct lun: getDeviceList is not sent when changing hosts
[admin-portal] direct lun: getDeviceList is not sent when changing hosts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.1.0
Assigned To: Daniel Erez
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 07:47 EDT by Haim
Modified: 2016-02-10 11:30 EST (History)
12 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-07-18 07:47:44 EDT
Description of problem:

new disk dialogue, choose external disk, getDeviceList should be sent to discover
all current luns host is familiar with, this doesn't happen also when changing between hosts.
it only happens after discovery. 
please implement the same logic as in new storage domain flow (for block devices).

repro steps:

- new disk 
- external disk 
- chose host and grep getDeviceList on vdsm.log.
Comment 1 Haim 2012-07-18 08:47:22 EDT
raising priority since its a blocker for testing direct lun with FC.
Comment 2 Daniel Erez 2012-07-22 09:06:44 EDT
upstream commit 6f3c946c2c312ab8ccbc06af38ae649e548d9ca4
Comment 4 Gadi Ickowicz 2012-07-29 07:08:23 EDT
getDeviceList is now sent as it should be on dialog open and when changing hosts.

from the vdsm.log:

Thread-8704::INFO::2012-07-29 14:04:25,864::logUtils::37::dispatcher::(wrapper) Run and protect: getDeviceList(storageType=3, options={})
Thread-8704::INFO::2012-07-29 14:04:27,310::logUtils::39::dispatcher::(wrapper) Run and protect: getDeviceList, Return response: {'devList': []}

Note You need to log in before you can comment on or make changes to this bug.