Bug 841197 - Beaker ignores tasks, no error reported
Beaker ignores tasks, no error reported
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.3
: ---
Assigned To: Bill Peck
: Reopened
: 645705 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 07:54 EDT by Petr Beňas
Modified: 2015-01-04 18:03 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 00:40:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Dan Callaghan 2012-07-30 20:12:17 EDT
This is expected behaviour. Your recipe is using RHEL5 Server and that task is excluded from RHEL5 Server, so Beaker discards it.

The Beaker server assumes that if you are submitting job XML directly, you know what you're doing and it takes the job as is. We rely on the tool which generated the job XML to pick the right tasks (for example, the bkr client workflow commands will complain if you use this task on RHEL5). In future the server may not enforce exclusions at all.
Comment 6 Bill Peck 2012-08-10 07:00:52 EDT
I'm re-opening this bug because I think its a mistake for beaker to filter when being given an xml.  The xml should already be filtered and this would allow task/test management outside of beaker in TCMS for example.
Comment 7 Bill Peck 2012-08-21 05:32:48 EDT
http://gerrit.beaker-project.org/#/c/1296/
Comment 8 Karel Srot 2012-08-24 01:30:36 EDT
On Thu, 2012-08-23 at 10:16 -0400, Bill Peck wrote:
Hello,
> 
> Beaker currently filters out tasks based on which Release and Arch is 
> being requested.  All of the current workflows filter out tasks that 
> don't apply to the requested Release and Arch.  
> 
I believe this is not true for workflow-tcms which is widely used in BaseOS QE and thus we are depending on the current behavior. I need to check with Petr Splichal whether he can fix it.
Comment 9 Bill Peck 2012-08-24 06:55:29 EDT
(In reply to comment #8)
> On Thu, 2012-08-23 at 10:16 -0400, Bill Peck wrote:
> Hello,
> > 
> > Beaker currently filters out tasks based on which Release and Arch is 
> > being requested.  All of the current workflows filter out tasks that 
> > don't apply to the requested Release and Arch.  
> > 
> I believe this is not true for workflow-tcms which is widely used in BaseOS
> QE and thus we are depending on the current behavior. I need to check with
> Petr Splichal whether he can fix it.

Thanks for checking on this.  That is kind of ironic since I thought this change was needed so that TCMS can actually manage the test plan. :-)
Comment 11 Dan Callaghan 2012-08-26 19:55:11 EDT
Marking this fix as verified, in that Beaker no longer filters tasks on the server side. However we are still waiting to see if it will be a problem for workflow-tcms.
Comment 12 Dan Callaghan 2012-09-03 02:36:36 EDT
*** Bug 645705 has been marked as a duplicate of this bug. ***
Comment 13 Dan Callaghan 2012-09-06 00:40:43 EDT
Beaker 0.9.3 has been released.

Note You need to log in before you can comment on or make changes to this bug.