Bug 841228 - logging in for first time doesn't seem to set user's organization permissions correctly
logging in for first time doesn't seem to set user's organization permissions...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 09:25 EDT by Tom McKay
Modified: 2013-08-16 13:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 11:19:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-07-18 09:25:48 EDT
Description of problem:

When logging in for the first time, even as admin, gives a "permission denied" on dashboard and shows no navigation tabs other than Dashboard. It is behaving as if the user does not have the proper roles for the chosen org.

Once I switch orgs through the org switcher (even to same org), everything loads fine from that point on.
Comment 1 Jason E. Rist 2012-08-15 17:18:37 EDT
Fixed in 2c31f616e01869007f3b05286611075dfe81ff9d
Comment 2 Bryan Kearney 2013-02-08 09:35:27 EST
This fix was delivered with 1.1. Moving to ON_QA in order to be verified.
Comment 3 Og Maciel 2013-02-08 11:19:54 EST
Verified by QA
Comment 4 Mike McCune 2013-08-16 13:50:58 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.