This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 841257 - [admin-portal] hot plug: cannot unplug direct lun disk while vm is running
[admin-portal] hot plug: cannot unplug direct lun disk while vm is running
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Gadi Ickowicz
storage
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 09:59 EDT by Haim
Modified: 2016-02-10 12:01 EST (History)
12 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Haim 2012-07-18 09:59:11 EDT
Description of problem:

cannot unplug direct lun disk while vm is running.
tailing engine.log, there is no command sent from admin-portal side to the engine.

repro steps:

- create a direct-lun disk 
- attach to vm 
- start vm
- click on deactivate 

expected results:

- disk should be unplugged 

if its by design (which i suspect not), please gray out the button.
Comment 2 Daniel Erez 2012-07-24 03:35:39 EDT
upstream commit 78928a48060938a02bfc60f4320ce56d2864ec7b
Comment 3 Haim 2012-07-29 06:36:04 EDT
verified on SI12 - unplug works, plugging back doesn't though its not related to UI since the command is sent to vdsm, libvirt fails to execute, closing this one as verified, will investigate and open a new one for responsible component.

Note You need to log in before you can comment on or make changes to this bug.