Bug 841366 - unable to change my email while the old email is not working
unable to change my email while the old email is not working
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: User Accounts (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 15:07 EDT by Waraqa
Modified: 2014-10-12 18:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 07:59:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Waraqa 2012-07-18 15:07:13 EDT
Description of problem:
I'm unable to change my email because my old email is no longer working

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. try to change your account email in bugzilla
2.
3.
  
Actual results:
It tries to send confirmation email to old email address

Expected results:
it should change the old address to new one if the old email is not working

Additional info:
my old email provider domain is down: gawab.com
Comment 1 Simon Green 2012-09-07 07:59:04 EDT
(In reply to comment #0)
> Description of problem:
> I'm unable to change my email because my old email is no longer working
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1. try to change your account email in bugzilla
> 2.
> 3.
>   
> Actual results:
> It tries to send confirmation email to old email address

The e-mail to the new e-mail address allows you to approve (or decline) the change. The e-mail to the old address allows that user to veto the address change.

Therefore you don't need access to the old e-mail address in order to make the change.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.