Bug 841437 - RFE-[WebTrans] entries that failed to save should be emphasized.
RFE-[WebTrans] entries that failed to save should be emphasized.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Unspecified
high Severity medium
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-18 21:57 EDT by Ding-Yi Chen
Modified: 2013-02-25 22:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121116-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-07-18 21:57:48 EDT
Description of problem:
Entries that failed to save or reach server look exactly like the successful ones.

This may confuse users by thinking their works are saved, which are actually discarded.

Indeed there are error messages on the notification panel. But emphasized entries should be more intuitive for translators.

Version-Release number of selected component (if applicable):
Zanata version 1.7-SNAPSHOT (20120719-0027)

How reproducible:
Always

Steps to Reproduce:
1. Sign in as a translator and Launch translation editor against locale, say XY
2. Sign in with another account as project maintainer, disable locale XY for that project
3. Translator type some message and save as approved.

  
Actual results:
The WebTrans looks as if the entry is saved, but actually it haven't.


Expected results:
The entry is emphasized by either reddish background, or have a small error icon.

Additional info:
Comment 1 Patrick Huang 2012-11-15 01:39:46 EST
With the unsaved indicator in 2.0 this bug should be closed. But since there is a bug 873525 for the unsaved indicator, I will leave this as ON_QA
Comment 2 Ding-Yi Chen 2012-11-16 01:59:11 EST
VERIFIED with
Zanata version 2.1-SNAPSHOT (20121112-1056) 
and Zanata version 2.0.3-SNAPSHOT (20121116-0019)

Note You need to log in before you can comment on or make changes to this bug.