Bug 841482 - IOException: Input/output error during write on /dev/sda
IOException: Input/output error during write on /dev/sda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:d3ed8734256e3a632889379e280...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 02:34 EDT by Mohit
Modified: 2012-07-19 07:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 07:57:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-Y6fvdL (425.46 KB, text/plain)
2012-07-19 02:35 EDT, Mohit
no flags Details

  None (edit)
Description Mohit 2012-07-19 02:34:58 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-7.fc16.x86_64
product:        Fedora
reason:         IOException: Input/output error during write on /dev/sda
time:           Thu Jul 19 12:02:35 2012
version:        16

anaconda-tb-Y6fvdL: Text file, 435671 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.25 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 221, in commitToDevice
:    return self.__disk.commit_to_dev()
:  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 274, in commitToDisk
:    self.partedDisk.commitToDevice()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 424, in doIt
:    dev.disk.format.commitToDisk()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1201, in nextClicked
:    self.anaconda.dispatch.go_forward()
:IOException: Input/output error during write on /dev/sda
Comment 1 Mohit 2012-07-19 02:35:04 EDT
Created attachment 599080 [details]
File: anaconda-tb-Y6fvdL
Comment 2 Vratislav Podzimek 2012-07-19 07:57:25 EDT
According to the /var/log/messages (the end of the file), it seems to be a hardware issue.

Jul 19 02:32:12 localhost kernel: [  128.506620] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.506624] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.506627] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.506633] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.506634]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.506637] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.506638] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.507987] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.507993] ata1: EH complete
Jul 19 02:32:12 localhost kernel: [  128.508797] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.508799] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.508802] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.508807] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.508808]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.508811] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.508813] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.510127] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.510134] ata1: EH complete
Jul 19 02:32:12 localhost kernel: [  128.510931] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.510934] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.510936] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.510941] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.510942]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.510945] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.510947] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.512300] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.512305] ata1: EH complete
Jul 19 02:32:12 localhost kernel: [  128.513351] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.513354] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.513357] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.513362] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.513363]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.513366] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.513369] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.514722] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.514728] ata1: EH complete
Jul 19 02:32:12 localhost kernel: [  128.515515] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.515518] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.515521] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.515526] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.515527]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.515530] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.515532] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.516805] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.516811] ata1: EH complete
Jul 19 02:32:12 localhost kernel: [  128.517591] ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Jul 19 02:32:12 localhost kernel: [  128.517594] ata1.00: BMDMA stat 0x4
Jul 19 02:32:12 localhost kernel: [  128.517596] ata1.00: failed command: WRITE DMA
Jul 19 02:32:12 localhost kernel: [  128.517601] ata1.00: cmd ca/00:28:00:00:00/00:00:00:00:00/e0 tag 0 dma 20480 out
Jul 19 02:32:12 localhost kernel: [  128.517602]          res 41/04:28:00:00:00/00:00:00:00:00/e0 Emask 0x1 (device error)
Jul 19 02:32:12 localhost kernel: [  128.517605] ata1.00: status: { DRDY ERR }
Jul 19 02:32:12 localhost kernel: [  128.517607] ata1.00: error: { ABRT }
Jul 19 02:32:12 localhost kernel: [  128.518903] ata1.00: configured for MWDMA2
Jul 19 02:32:12 localhost kernel: [  128.518912] sd 0:0:0:0: [sda]  Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Jul 19 02:32:12 localhost kernel: [  128.518915] sd 0:0:0:0: [sda]  Sense Key : Aborted Command [current] [descriptor]
Jul 19 02:32:12 localhost kernel: [  128.518919] Descriptor sense data with sense descriptors (in hex):
Jul 19 02:32:12 localhost kernel: [  128.518921]         72 0b 00 00 00 00 00 0c 00 0a 80 00 00 00 00 00 
Jul 19 02:32:12 localhost kernel: [  128.518929]         00 00 00 00 
Jul 19 02:32:12 localhost kernel: [  128.518932] sd 0:0:0:0: [sda]  Add. Sense: No additional sense information
Jul 19 02:32:12 localhost kernel: [  128.518936] sd 0:0:0:0: [sda] CDB: Write(10): 2a 00 00 00 00 00 00 00 28 00
Jul 19 02:32:12 localhost kernel: [  128.518943] end_request: I/O error, dev sda, sector 0
Jul 19 02:32:12 localhost kernel: [  128.518947] Buffer I/O error on device sda, logical block 0
Jul 19 02:32:12 localhost kernel: [  128.518948] lost page write due to I/O error on sda
Jul 19 02:32:12 localhost kernel: [  128.518975] Buffer I/O error on device sda, logical block 1
Jul 19 02:32:12 localhost kernel: [  128.518977] lost page write due to I/O error on sda
Jul 19 02:32:12 localhost kernel: [  128.518981] Buffer I/O error on device sda, logical block 2
Jul 19 02:32:12 localhost kernel: [  128.518982] lost page write due to I/O error on sda
Jul 19 02:32:12 localhost kernel: [  128.518985] Buffer I/O error on device sda, logical block 3
Jul 19 02:32:12 localhost kernel: [  128.518987] lost page write due to I/O error on sda
Jul 19 02:32:12 localhost kernel: [  128.518990] Buffer I/O error on device sda, logical block 4
Jul 19 02:32:12 localhost kernel: [  128.518992] lost page write due to I/O error on sda
Jul 19 02:32:12 localhost kernel: [  128.519003] ata1: EH complete

Note You need to log in before you can comment on or make changes to this bug.