Bug 841512 - [engine-core] auto-recovery: SPM election loop if auto-recovery tries to activate non-existing storage domain
[engine-core] auto-recovery: SPM election loop if auto-recovery tries to acti...
Status: CLOSED DUPLICATE of bug 821634
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Liron Aravot
Haim
storage
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 05:18 EDT by Haim
Modified: 2016-02-10 12:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 01:57:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log. (316.05 KB, application/x-gzip)
2012-07-19 05:20 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-07-19 05:18:59 EDT
Description of problem:

we should have the ability to understand if domain is no longer exists (activate storage domain returns with se.StorageDomainDoesNotExist), so there is no point of failing the pool (SPM re-election) every 5 minutes, currently, i'm stuck with SPM re-election storm.

repro steps:

- delete storage domain from storage server itself
- let auto-recovery do the rest
Comment 1 Haim 2012-07-19 05:20:52 EDT
Created attachment 599097 [details]
engine log.
Comment 3 Ayal Baron 2012-07-23 02:24:14 EDT
There is no way to differentiate between storage domain is dead and storage domain is not visible to host due to storage disconnect / admin misconfiguration / etc.

Also, if there is an additional storage domain then system would initiate a reconstructMaster flow.

In addition, user can deactivate sd/destroy sd/reinitialize DC  and stop this from happening.

Closing as not a bug
Comment 5 Ayal Baron 2012-08-01 09:43:38 EDT
You are correct.  What we should do is prevent spm reselection if domain is not visible on other hosts (i.e. activate will fail there as well)
Comment 6 mkublin 2012-08-05 06:53:03 EDT
*** Bug 845294 has been marked as a duplicate of this bug. ***
Comment 7 Ayal Baron 2012-08-06 01:57:10 EDT

*** This bug has been marked as a duplicate of bug 821634 ***

Note You need to log in before you can comment on or make changes to this bug.