Bug 841544 - Win2008r2 guest fail to get IP address after executed system_reset many times with virtio nic
Win2008r2 guest fail to get IP address after executed system_reset many times...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 07:04 EDT by xu
Modified: 2013-02-21 05:40 EST (History)
14 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-39
Doc Type: Bug Fix
Doc Text:
Cause: Wrong initialization sequence of virtio-net on Windows Consequence: Sometimes the first packets that were sent through the interface (DHCP client) were stack in the queue for a long time and thus DHCP client was failing to receive IP address. Fix: Init sequence fixed. Result: Network always works after power management event or disable\enable.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:40:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
out put of "tcpdump -i eth0 -vvv -s 1500 '(port 67 or port 68) and (udp[38:4]=0x7d1c32a0)' " on host (38.98 KB, text/x-log)
2012-07-19 07:05 EDT, xu
no flags Details
tcpdump out put with virtio nic (76.00 KB, application/octet-stream)
2012-07-24 04:38 EDT, xu
no flags Details
tcpdump out put with rtl8139 nic (40.00 KB, application/octet-stream)
2012-07-24 04:38 EDT, xu
no flags Details
tcpdump out put with e1000 nic (36.00 KB, application/octet-stream)
2012-07-24 04:40 EDT, xu
no flags Details

  None (edit)
Comment 1 xu 2012-07-19 07:05:36 EDT
Created attachment 599114 [details]
out put of "tcpdump -i eth0  -vvv -s 1500 '(port 67 or port 68) and (udp[38:4]=0x7d1c32a0)' " on host
Comment 3 Miya Chen 2012-07-22 22:16:26 EDT
xu, do you hit the same issue with e1000 or rtl8139?
Comment 5 xu 2012-07-24 04:38:01 EDT
Created attachment 599937 [details]
tcpdump out put with virtio nic
Comment 6 xu 2012-07-24 04:38:48 EDT
Created attachment 599938 [details]
tcpdump out put with rtl8139 nic
Comment 7 xu 2012-07-24 04:40:41 EDT
Created attachment 599941 [details]
tcpdump out put with e1000 nic
Comment 10 xu 2012-09-05 05:42:30 EDT
(In reply to comment #9)
> http://git.engineering.redhat.com/?p=users/yvugenfi/internal-kvm-guest-
> drivers-windows/.git;a=commit;h=75d6526dd2aa56f6efc081262dcf36b02ed2ece6

Hi Vugenfirer, thanks for your patch. Is there any packages avaliable for me to have a try;

Xu
Comment 11 Yan Vugenfirer 2012-09-30 08:10:28 EDT
Hi Xu,

Build 37 should include this fix.

Thanks,
Yan.
Comment 16 Miya Chen 2012-10-11 06:14:17 EDT
Change to the right component and fixed version, correct me if I were wrong.
Comment 19 Mike Cao 2012-10-12 03:55:50 EDT
Based on comment #15 ,this issue has been passed 

move status to verified .
Comment 24 errata-xmlrpc 2013-02-21 05:40:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0441.html

Note You need to log in before you can comment on or make changes to this bug.