Bug 841559 - Webadmin sends "0.0.0.0" as gateway for non-management networks by default
Webadmin sends "0.0.0.0" as gateway for non-management networks by default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Alona Kaplan
GenadiC
network
: Regression
Depends On: 842137
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 07:57 EDT by Moti Asayag
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moti Asayag 2012-07-19 07:57:34 EDT
Description of problem:
When non-management network is set with static-ip and subnet mask via SetupNetworks, the gateway is being set with "0.0.0.0" rather empty (null).

The backend allows reciving that value, therefore the result is a network script containing that record.

Version-Release number of selected component (if applicable):

How reproducible:
always

Steps to Reproduce:
1. Using SetupNetworks, create a network on the host and set its boot protocol to static ip.
2. Provide ip and subnet mask and confirm the dialog.
  
Actual results:
The record GATEWAY=0.0.0.0 appears in the network script:

[root@myhost02 network-scripts]# cat ifcfg-testnet
DEVICE=testnet
TYPE=Bridge
ONBOOT=yes
IPADDR=10.10.10.10
NETMASK=255.255.255.0
GATEWAY=0.0.0.0
DELAY=0
NM_CONTROLLED=no

Expected results:
No GATEWAY record should appear.
[root@myhost02 network-scripts]# cat ifcfg-testnet
DEVICE=testnet
TYPE=Bridge
ONBOOT=yes
IPADDR=10.10.10.10
NETMASK=255.255.255.0
DELAY=0
NM_CONTROLLED=no

Additional info:
Comment 2 Moti Asayag 2012-07-25 05:12:51 EDT
Commit-id: bd9aa2adcca10d6e61585e68d0822949d1a888f9

The change is made on backend side. Since backend doesn't report any gateway for non-management network, the webadmin will not return any value for it.
Comment 3 Meni Yakove 2012-07-29 05:16:14 EDT
Verified on vdsm-4.9.6-24.0.el6_3.x86_64.

cat /etc/sysconfig/network-scripts/ifcfg-net1 
DEVICE=net1
TYPE=Bridge
ONBOOT=yes
IPADDR=1.1.1.1
NETMASK=255.255.255.0
DELAY=0
NM_CONTROLLED=no
STP=no

Note You need to log in before you can comment on or make changes to this bug.