Bug 841562 - pnp4nagios not generating performace data graphs
pnp4nagios not generating performace data graphs
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pnp4nagios (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan ONDREJ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 08:18 EDT by James Hill
Modified: 2012-07-24 11:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 11:43:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hill 2012-07-19 08:18:32 EDT
Description of problem:
Within nagios, pnp4nagios has been configured to produce graphs of performace data. Up until the last yum update of system these graphs displayed properly. 

Now all thatsd produced is blank pages where graphs should be.

Version-Release number of selected component (if applicable):
nagios.i686 3.4.1-2.fc17 
pnp4nagios.i686 0.6.16-2.fc17 
rrdtool.i686 1.4.7-5.fc17                                                      rrdtool-perl.i686 1.4.7-5.fc17   

How reproducible:
2 different servers at independent sites now producing same results.

Steps to Reproduce:
1. Install and configure Nagios and pnp4nagios using install dvd.
2. Collect data and test performace data graphs
3. update using yum
  
Actual results:
Blank screen. 

Expected results:
Graphs of performace data

Additional info:
Last working update via yum was end of june.  Performed yum update on 16th July, pnp4nagios stopped working then. Can't narrow it down to more that pnp4nagios or the rrdtool.
Comment 1 Jan ONDREJ 2012-07-19 08:39:14 EDT
There is no pnp4nagios or rrdtool update in fedora 17 stable updates.
Is it possible, that you updated your system from Fedora 16? Fedora 16 has older version of php4nagios, which is not fully compatible and if you configured pnp4nagios manually in a different way like this new update is know, you have to update your nagios configuration.

Altrough there is an nagios update in Fedora 17 stable updates, I don't know about any problem, why this should happen. On my Fedora 16 I don't see any problems with updating pnp4nagios graphs.

Can you try to check, if your rrd files have been updated on disk?
Can you check your logs or try to manually run pnp4nagios to debug this problem?
Comment 2 James Hill 2012-07-19 09:01:34 EDT
Hi

Yes, both serves were indeed 'preupgraded' from Fedora 16 but have been working up to this point. The pnp4nagios is the yum package from the updates repository and was working prior to the update done on July 16th.  Last update prior to that was at the end of June.

Most of the eprformace data does appear to be collected.

Within the /var/log/pnp4nagios/perfdata.log file I'm seeing this error:

2012-07-19 10:06:00 [5099] [0] RRDs::update ERROR /var/lib/pnp4nagios//.pnp-internal/runtime_create.rrd: illegal attempt to update using time 1342688759 when last update time is 1342688787 (minimum one second step)
 
Within the file /var/log/nagios/nagios.log i'm seeing this error:

[1342702768] Warning: Attempting to execute the command "/usr/bin/perl /usr/libexec/pnp4nagios/process_perfdata.pl -d rta=0.398000ms;3000.000000;5000.000000;0.000000 pl=0%;80;100;0" resulted in a return code of 127.  Make sure the script or binary you are trying to execute actually exists...

The files within /var/lib/pnp4nagios appear to be updateing with data.


From logwatch:
--------------------- yum Begin ------------------------ 

 
 Packages Installed:
    libupnp-1.6.13-3.fc17.i686
    1:faad2-libs-2.7-2.fc17.i686
    redhat-lsb-core-4.1-4.fc17.i686
    qt3-3.3.8b-41.fc17.i686
    perl-ExtUtils-MakeMaker-6.62-2.fc17.noarch
    redhat-lsb-printing-4.1-4.fc17.i686
    libcddb-1.3.2-8.fc17.i686
    perl-Locale-Codes-3.22-1.fc17.noarch
    perl-HTTP-Tiny-0.012-212.fc17.noarch
    1:grub2-tools-2.0-0.37.beta6.fc17.i686
    patch-2.6.1-12.fc17.i686
    lirc-libs-0.9.0-8.fc17.i686
    a52dec-0.7.4-16.fc17.i686
    rpmfusion-free-release-15-5.noarch
    perl-CPAN-1.9600.01-212.fc17.noarch
    libdca-0.0.5-6.fc17.i686
    redhat-lsb-submod-security-4.1-4.fc17.i686
    libmatroska-1.3.0-2.fc17.i686
    libmpeg2-0.5.1-9.fc17.i686
    ffmpeg-libs-0.10.4-1.fc17.i686
    perl-Class-ISA-0.36-1007.fc17.noarch
    vlc-2.0.2-1.fc17.i686
    SDL_image-1.2.12-1.fc17.i686
    vlc-core-2.0.2-1.fc17.i686
    zvbi-0.2.33-12.fc17.i686
    redhat-lsb-4.1-4.fc17.i686
    lame-libs-3.99.5-1.fc17.i686
    systemtap-sdt-devel-1.8-1.fc17.i686
    libdvbpsi-0.2.2-2.fc17.i686
    freeglut-2.8.0-3.fc17.i686
    flash-plugin-11.2.202.236-release.i386
    libprojectM-2.0.1-15.fc17.i686
    perl-Pod-Plainer-1.03-1.fc17.noarch
    perl-Test-Harness-3.23-212.fc17.noarch
    perl-Test-Simple-0.98-212.fc17.noarch
    redhat-lsb-submod-multimedia-4.1-4.fc17.i686
    game-music-emu-0.5.5-2.fc17.i686
    google-chrome-stable-20.0.1132.57-145807.i386
    ftgl-2.1.3-0.5.rc5.fc17.i686
    librtmp-2.4-0.2.20110811gitc58cfb3e.fc17.i686
    1:perl-ExtUtils-ParseXS-2.2210-212.fc17.noarch
    perl-ExtUtils-Manifest-1.60-1.fc17.noarch
    redhat-lsb-languages-4.1-4.fc17.i686
    libcaca-0.99-0.14.beta17.fc17.i686
    libmad-0.15.1b-14.fc17.i686
    rpmfusion-nonfree-release-15-5.noarch
    xvidcore-1.3.2-3.fc17.i686
    4:perl-devel-5.14.2-212.fc17.i686
    twolame-libs-0.3.13-2.fc17.i686
    redhat-lsb-desktop-4.1-4.fc17.i686
    libtiger-0.3.4-3.fc17.i686
    kernel-3.4.4-5.fc17.i686
    minizip-1.2.5-6.fc17.i686
    pax-3.4-13.fc17.i686
    libva-1.0.15-2.fc17.i686
    openal-soft-1.14-2.fc17.i686
    libebml-1.2.2-2.fc17.i686
    redhat-lsb-cxx-4.1-4.fc17.i686
    adobe-release-i386-1.0-1.noarch
    perl-ExtUtils-Install-1.56-212.fc17.noarch
    x264-libs-0.120-5.20120303.fc17.i686
    live555-0-0.37.2012.04.27.fc17.i686
    iniparser-3.0-1.fc17.i686
    libtar-1.2.11-22.fc17.i686
 
 Packages Updated:
    xorg-x11-server-common-1.12.2-4.fc17.i686
    nagios-plugins-real-1.4.15-7.fc17.i686
    libunistring-0.9.3-5.fc17.i686
    libffado-2.1.0-0.9.20120325.svn2088.fc17.i686
    nagios-plugins-smtp-1.4.15-7.fc17.i686
    evolution-NetworkManager-3.4.3-2.fc17.i686
    cyrus-sasl-plain-2.1.23-30.fc17.i686
    PackageKit-device-rebind-0.7.5-1.fc17.i686
    libpurple-2.10.5-1.fc17.i686
    libvisio-0.0.18-1.fc17.i686
    python-setuptools-0.6.27-2.fc17.noarch
    hplip-3.12.6-1.fc17.i686
    nagios-plugins-ssh-1.4.15-7.fc17.i686
    nagios-plugins-rpc-1.4.15-7.fc17.i686
    php-gd-5.4.4-4.fc17.i686
    php-5.4.4-4.fc17.i686
    php-dba-5.4.4-4.fc17.i686
    gdb-7.4.50.20120120-49.fc17.i686
    libsss_sudo-1.8.4-14.fc17.i686
    nagios-plugins-procs-1.4.15-7.fc17.i686
    php-pecl-ncurses-1.0.2-1.fc17.i686
    nagios-plugins-ifstatus-1.4.15-7.fc17.i686
    nagios-plugins-load-1.4.15-7.fc17.i686
    libtdb-1.2.10-15.fc17.i686
    libudisks2-1.94.0-7.fc17.i686
    nagios-plugins-wave-1.4.15-7.fc17.i686
    initscripts-9.37.1-1.fc17.i686
    jack-audio-connection-kit-1.9.8-9.fc17.i686
    pygobject2-2.28.6-5.fc17.i686
    nagios-plugins-by_ssh-1.4.15-7.fc17.i686
    php-cli-5.4.4-4.fc17.i686
    rpmfusion-free-release-17.0.3-1.noarch
    lensfun-0.2.5-8.fc17.i686
    nagios-plugins-dns-1.4.15-7.fc17.i686
    podofo-libs-0.9.1-6.fc17.i686
    qt-settings-4.8-16.fc17.noarch
    PackageKit-yum-0.7.5-1.fc17.i686
    libldb-1.1.6-1.fc17.i686
    1:nfs-utils-1.2.6-3.fc17.i686
    1:grub2-2.0-0.37.beta6.fc17.i686
    mesa-libglapi-8.0.3-3.fc17.i686
    libsane-hpaio-3.12.6-1.fc17.i686
    php-pdo-5.4.4-4.fc17.i686
    nagios-plugins-disk_smb-1.4.15-7.fc17.i686
    sendmail-8.14.5-14.fc17.i686
    php-mssql-5.4.4-4.fc17.i686
    telepathy-gabble-0.16.1-1.fc17.i686
    php-odbc-5.4.4-4.fc17.i686
    evolution-3.4.3-2.fc17.i686
    nagios-plugins-ircd-1.4.15-7.fc17.i686
    slv2-0.6.6-9.fc17.i686
    nagios-plugins-mysql-1.4.15-7.fc17.i686
    nagios-plugins-mailq-1.4.15-7.fc17.i686
    PackageKit-yum-plugin-0.7.5-1.fc17.i686
    accountsservice-libs-0.6.21-2.fc17.i686
    selinux-policy-doc-3.10.0-134.fc17.noarch
    nagios-plugins-mrtgtraf-1.4.15-7.fc17.i686
    cyrus-sasl-2.1.23-30.fc17.i686
    php-soap-5.4.4-4.fc17.i686
    php-snmp-5.4.4-4.fc17.i686
    nagios-plugins-ldap-1.4.15-7.fc17.i686
    vte-0.28.2-6.fc17.i686
    gd-2.0.35-17.fc17.i686
    php-intl-5.4.4-4.fc17.i686
    yum-langpacks-0.2.5-1.fc17.noarch
    rpmfusion-nonfree-release-17.0.3-1.noarch
    nagios-3.4.1-2.fc17.i686
    PackageKit-gtk3-module-0.7.5-1.fc17.i686
    nagios-plugins-swap-1.4.15-7.fc17.i686
    libipa_hbac-1.8.4-14.fc17.i686
    dvb-apps-1.1.2-1.1479.37781d27a444.fc17.i686
    gimp-help-2.8.0-2.fc17.noarch
    mesa-libxatracker-8.0.3-3.fc17.i686
    1:qt-4.8.2-4.fc17.i686
    php-mbstring-5.4.4-4.fc17.i686
    nagios-plugins-oracle-1.4.15-7.fc17.i686
    PackageKit-glib-0.7.5-1.fc17.i686
    nagios-plugins-http-1.4.15-7.fc17.i686
    nagios-plugins-flexlm-1.4.15-7.fc17.i686
    openconnect-lib-compat-4.04-1.fc17.i686
    nagios-plugins-mrtg-1.4.15-7.fc17.i686
    elfutils-libelf-0.154-1.fc17.i686
    mysql-5.5.25a-1.fc17.i686
    nagios-plugins-perl-1.4.15-7.fc17.i686
    xorg-x11-server-Xephyr-1.12.2-4.fc17.i686
    php-imap-5.4.4-4.fc17.i686
    1:hpijs-3.12.6-1.fc17.i686
    telepathy-glib-0.18.1-2.fc17.i686
    2:libsmbclient-3.6.6-91.fc17.1.i686
    php-xml-5.4.4-4.fc17.i686
    xkeyboard-config-2.5.1-3.fc17.noarch
    php-ldap-5.4.4-4.fc17.i686
    elfutils-0.154-1.fc17.i686
    php-devel-5.4.4-4.fc17.i686
    mesa-dri-filesystem-8.0.3-3.fc17.i686
    nagios-plugins-dig-1.4.15-7.fc17.i686
    setroubleshoot-3.1.12-1.fc17.i686
    python-boto-2.5.1-1.fc17.noarch
    nagios-plugins-icmp-1.4.15-7.fc17.i686
    PackageKit-command-not-found-0.7.5-1.fc17.i686
    2:samba-winbind-clients-3.6.6-91.fc17.1.i686
    nagios-plugins-overcr-1.4.15-7.fc17.i686
    accountsservice-0.6.21-2.fc17.i686
    systemd-44-17.fc17.i686
    xorg-x11-server-Xorg-1.12.2-4.fc17.i686
    nagios-plugins-sensors-1.4.15-7.fc17.i686
    mobile-broadband-provider-info-1.20120614-1.fc17.noarch
    hplip-common-3.12.6-1.fc17.i686
    libtevent-0.9.16-1.fc17.i686
    php-pgsql-5.4.4-4.fc17.i686
    libmapi-7.0.8-1.fc17.i686
    cyrus-sasl-md5-2.1.23-30.fc17.i686
    php-pspell-5.4.4-4.fc17.i686
    NetworkManager-openconnect-0.9.4.0-7.git20120612.fc17.i686
    1:xscreensaver-base-5.18-2.fc17.i686
    mysql-libs-5.5.25a-1.fc17.i686
    nagios-plugins-tcp-1.4.15-7.fc17.i686
    selinux-policy-targeted-3.10.0-134.fc17.noarch
    1:folks-0.6.9-2.fc17.i686
    empathy-3.4.2.3-1.fc17.i686
    hplip-libs-3.12.6-1.fc17.i686
    nagios-plugins-disk-1.4.15-7.fc17.i686
    systemd-sysv-44-17.fc17.i686
    rsyslog-5.8.10-2.fc17.i686
    grep-2.13-1.fc17.i686
    vlgothic-fonts-common-20120629-1.fc17.noarch
    nagios-plugins-fping-1.4.15-7.fc17.i686
    nagios-plugins-dhcp-1.4.15-7.fc17.i686
    nagios-plugins-file_age-1.4.15-7.fc17.i686
    nagios-plugins-ping-1.4.15-7.fc17.i686
    nagios-plugins-log-1.4.15-7.fc17.i686
    nagios-plugins-nwstat-1.4.15-7.fc17.i686
    bash-4.2.36-1.fc17.i686
    selinux-policy-3.10.0-134.fc17.noarch
    webkitgtk3-1.8.1-3.fc17.i686
    systemd-analyze-44-17.fc17.i686
    nagios-plugins-ifoperstatus-1.4.15-7.fc17.i686
    hplip-gui-3.12.6-1.fc17.i686
    mdadm-3.2.5-3.fc17.i686
    php-mcrypt-5.4.4-4.fc17.i686
    2:samba-common-3.6.6-91.fc17.1.i686
    php-mysql-5.4.4-4.fc17.i686
    php-common-5.4.4-4.fc17.i686
    nagios-plugins-pgsql-1.4.15-7.fc17.i686
    1:qt-x11-4.8.2-4.fc17.i686
    xorg-x11-drv-modesetting-0.4.0-1.fc17.i686
    nagios-plugins-ups-1.4.15-7.fc17.i686
    PackageKit-0.7.5-1.fc17.i686
    nagios-plugins-nagios-1.4.15-7.fc17.i686
    mesa-dri-drivers-8.0.3-3.fc17.i686
    nagios-plugins-time-1.4.15-7.fc17.i686
    zarafa-common-7.0.8-1.fc17.noarch
    1:gnome-bluetooth-libs-3.4.2-1.fc17.i686
    mesa-libGL-8.0.3-3.fc17.i686
    PackageKit-gstreamer-plugin-0.7.5-1.fc17.i686
    1:gnome-bluetooth-3.4.2-1.fc17.i686
    nagios-plugins-ide_smart-1.4.15-7.fc17.i686
    mysql-server-5.5.25a-1.fc17.i686
    php-bcmath-5.4.4-4.fc17.i686
    dracut-018-78.git20120622.fc17.noarch
    nagios-plugins-hpjd-1.4.15-7.fc17.i686
    zarafa-client-7.0.8-1.fc17.i686
    selinux-policy-devel-3.10.0-134.fc17.noarch
    sssd-1.8.4-14.fc17.i686
    elfutils-libs-0.154-1.fc17.i686
    setroubleshoot-server-3.1.12-1.fc17.i686
    cyrus-sasl-gssapi-2.1.23-30.fc17.i686
    nagios-plugins-all-1.4.15-7.fc17.i686
    mesa-libGLU-8.0.3-3.fc17.i686
    nagios-plugins-dummy-1.4.15-7.fc17.i686
    nagios-plugins-ntp-1.4.15-7.fc17.i686
    nagios-common-3.4.1-2.fc17.i686
    vlgothic-fonts-20120629-1.fc17.noarch
    nagios-plugins-users-1.4.15-7.fc17.i686
    nagios-plugins-snmp-1.4.15-7.fc17.i686
    pam-1.1.5-7.fc17.i686
    openconnect-4.04-1.fc17.i686
    2:libwbclient-3.6.6-91.fc17.1.i686
    2:samba-client-3.6.6-91.fc17.1.i686
    nagios-plugins-cluster-1.4.15-7.fc17.i686
    cyrus-sasl-lib-2.1.23-30.fc17.i686
    nagios-plugins-1.4.15-7.fc17.i686
    nagios-plugins-nt-1.4.15-7.fc17.i686
    udisks2-1.94.0-7.fc17.i686
    sssd-client-1.8.4-14.fc17.i686
    2:samba-3.6.6-91.fc17.1.i686
    nagios-plugins-game-1.4.15-7.fc17.i686
    php-mapi-7.0.8-1.fc17.i686
    python-httplib2-0.7.4-4.fc17.noarch
    nagios-plugins-breeze-1.4.15-7.fc17.i686
    libtiff-3.9.6-1.fc17.i686
 
 ---------------------- yum End -------------------------
Comment 3 Jan ONDREJ 2012-07-19 09:20:11 EDT
(In reply to comment #2)
> Hi
> 
> Yes, both serves were indeed 'preupgraded' from Fedora 16 but have been
> working up to this point. The pnp4nagios is the yum package from the updates
> repository and was working prior to the update done on July 16th.  Last
> update prior to that was at the end of June.

Can you point me to URL of pnp4nagios update for Fedora 17?
I can't find it, because it doesn't exist.

> Within the /var/log/pnp4nagios/perfdata.log file I'm seeing this error:
> 
> 2012-07-19 10:06:00 [5099] [0] RRDs::update ERROR
> /var/lib/pnp4nagios//.pnp-internal/runtime_create.rrd: illegal attempt to
> update using time 1342688759 when last update time is 1342688787 (minimum
> one second step)

Looks like your time is going back. :-)
This isn't a pnp4nagios problem. Try to check your time.
 
> 
> From logwatch:
> --------------------- yum Begin ------------------------ 
> 
>  
>  Packages Installed:
...
>  Packages Updated:
...
>  ---------------------- yum End -------------------------

Can you see pnp4nagios in list of packages installed/updated? I don't.
Comment 4 James Hill 2012-07-19 11:19:05 EDT
Seem have gone down the wrong direction with suspecting the applications themselves.

What I have noticed is that when i hover over the link (for a service) I'll see:

/nagios/pnp4nagios/index.php?host=$HOSTNAME$&srv=$SERVICEDESC$

What I'm seeing in the URL of the page when I click on it is:

/pnp4nagios/graph?host=$HOSTNAME$

Where in this case, the hostname is the first hostname and not even the correct hostname of the service selected.

Below is my pnp4nagios.conf
Could there be aq rewrite problem with this (ie is it actually the rewrite mod or this config causing my problem?)

Alias /pnp4nagios "/usr/share/nagios/html/pnp4nagios/"

<Directory "/usr/share/nagios/html/pnp4nagios/">
        AllowOverride None
        Order allow,deny
        Allow from all
        #
        # Use the same value as defined in nagios.conf
        #
        AuthName "Nagios Access"
        AuthType Basic
        AuthUserFile /etc/nagios/htpasswd.users
        Require valid-user
        <IfModule mod_rewrite.c>
                # Turn on URL rewriting
                RewriteEngine On
                Options FollowSymLinks
                # Installation directory
                RewriteBase /pnp4nagios/
                # Protect application and system files from being viewed
                RewriteRule ^(application|modules|system) - [F,L]
                # Allow any files or directories that exist to be displayed directly
                RewriteCond %{REQUEST_FILENAME} !-f
                RewriteCond %{REQUEST_FILENAME} !-d
                # Rewrite all other URLs to index.php/URL
                RewriteRule .* index.php/$0 [PT,L]
        </IfModule>
</Directory>
Comment 5 James Hill 2012-07-19 11:20:01 EDT
erased and reinsatlled the following just to be sure.

pnp4nagios 
rrdtool
rrdtool-perl
Comment 6 Jan ONDREJ 2012-07-19 13:03:19 EDT
(In reply to comment #4)
> What I have noticed is that when i hover over the link (for a service) I'll
> see:
> 
> /nagios/pnp4nagios/index.php?host=$HOSTNAME$&srv=$SERVICEDESC$
> 
> What I'm seeing in the URL of the page when I click on it is:
> 
> /pnp4nagios/graph?host=$HOSTNAME$
> 
> Where in this case, the hostname is the first hostname and not even the
> correct hostname of the service selected.

Yes, this is a known problem of upgrading pnp4nagios-0.4 to 0.6.
It's not enough to change URLs. Because URLs to these graphs are coded into your configuration, you need to update your config.

If you can write an universal solution, which will work for all users and does not break any of their links, I will add it into Fedora's pnp4nagios package.

If don't, please close this bug as "unable to fix".
Comment 7 James Hill 2012-07-24 11:42:26 EDT
  
This will probably be fixed upstream.  kohana.php file in pnp4nagios has slight incompatibility with php 5.4, just needs one line changed.

Also note that the command 'index.php' needs changed to 'draft' for the URL's to work correctly.


Found this snip of code:

--- /usr/share/nagios/html/pnp4nagios/kohana/system/core/Kohana.php
+++ /usr/share/nagios/html/pnp4nagios/kohana/system/core/Kohana.php
@@ -719,7 +719,8 @@ final class Kohana {
                        }
 
                        // Store the Kohana output buffer
-                       ob_end_clean();
+                       //ob_end_clean();
+                       ob_end_flush(); // Fixed for PHP 5.4
                }
        }

Note You need to log in before you can comment on or make changes to this bug.