Bug 841673 - SELinux is preventing /usr/sbin/tmpwatch from 'rmdir' accesses on the directory squid.old.
SELinux is preventing /usr/sbin/tmpwatch from 'rmdir' accesses on the directo...
Status: CLOSED DUPLICATE of bug 841672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8abba3497ad89e4262458d5afa9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 16:18 EDT by zic
Modified: 2012-07-19 18:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 18:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zic 2012-07-19 16:18:54 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-5.fc17.x86_64
time:           Fri 20 Jul 2012 05:18:35 AM JST

description:
:SELinux is preventing /usr/sbin/tmpwatch from 'rmdir' accesses on the directory squid.old.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that tmpwatch should be allowed rmdir access on the squid.old directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep tmpwatch /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tmpreaper_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:squid_cache_t:s0
:Target Objects                squid.old [ dir ]
:Source                        tmpwatch
:Source Path                   /usr/sbin/tmpwatch
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           tmpwatch-2.10.3-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-137.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed).Tahri 3.4.4-5.fc17.x86_64 #1 SMP Thu
:                              Jul 5 20:20:59 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 20 Jul 2012 03:36:20 AM JST
:Last Seen                     Fri 20 Jul 2012 03:36:20 AM JST
:Local ID                      ddb59126-0f26-467a-82b6-c576b8b23781
:
:Raw Audit Messages
:type=AVC msg=audit(1342722980.348:277138): avc:  denied  { rmdir } for  pid=29596 comm="tmpwatch" name="squid.old" dev="md112" ino=1179656 scontext=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:squid_cache_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1342722980.348:277138): arch=x86_64 syscall=rmdir success=no exit=EACCES a0=1b53c13 a1=404848 a2=1b52120 a3=404a7d items=0 ppid=29594 pid=29596 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=531 comm=tmpwatch exe=/usr/sbin/tmpwatch subj=system_u:system_r:tmpreaper_t:s0-s0:c0.c1023 key=(null)
:
:Hash: tmpwatch,tmpreaper_t,squid_cache_t,dir,rmdir
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-19 18:01:07 EDT

*** This bug has been marked as a duplicate of bug 841672 ***

Note You need to log in before you can comment on or make changes to this bug.