Bug 841674 - SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /var/log/sa/sar10.
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /var/log...
Status: CLOSED DUPLICATE of bug 841672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:883bbd26839a5adaecc667dccdd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-19 16:21 EDT by zic
Modified: 2012-07-19 18:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 18:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zic 2012-07-19 16:21:08 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-5.fc17.x86_64
time:           Fri 20 Jul 2012 05:20:50 AM JST

description:
:SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /var/log/sa/sar10.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rm should be allowed unlink access on the sar10 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sysstat_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:var_log_t:s0
:Target Objects                /var/log/sa/sar10 [ file ]
:Source                        rm
:Source Path                   /usr/bin/rm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-137.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed).Tahri 3.4.4-5.fc17.x86_64 #1 SMP Thu
:                              Jul 5 20:20:59 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Thu 19 Jul 2012 11:53:01 PM JST
:Last Seen                     Thu 19 Jul 2012 11:53:01 PM JST
:Local ID                      ee142d70-aa51-4184-a424-2a45a9bedba9
:
:Raw Audit Messages
:type=AVC msg=audit(1342709581.929:210313): avc:  denied  { unlink } for  pid=26375 comm="rm" name="sar10" dev="md114" ino=131099 scontext=system_u:system_r:sysstat_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_log_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1342709581.929:210313): arch=x86_64 syscall=unlinkat success=no exit=EACCES a0=ffffffffffffff9c a1=173a0f0 a2=0 a3=20 items=0 ppid=26372 pid=26375 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=474 comm=rm exe=/usr/bin/rm subj=system_u:system_r:sysstat_t:s0-s0:c0.c1023 key=(null)
:
:Hash: rm,sysstat_t,var_log_t,file,unlink
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-19 18:01:12 EDT

*** This bug has been marked as a duplicate of bug 841672 ***

Note You need to log in before you can comment on or make changes to this bug.