Bug 841749 - [RFE] server config parameter to set external URL
[RFE] server config parameter to set external URL
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.2
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 02:53 EDT by Jun'ichi NOMURA
Modified: 2012-08-16 18:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:06:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun'ichi NOMURA 2012-07-20 02:53:00 EDT
[RFE] server config parameter to set external URL

Suppose following network configuration for testing lab:

  +---------+
  | desktop |
  +----+----+                            external network
       |
       |
       | www.testlab.com
  +----+-----+
  |  rproxy  | = = = = = = = = = = = = = = = = = = = = =
  +----+-----+
       | rproxy.localdomain
       |
       +---------------------------+     lab-private network
       |                           |
       | beaker.localdomain        |
  +----+-----+                     |
  |  beaker  |                     |
  +----------+                     |
                    +--------------+-------------------
                    |              |
             +------+-----+  +-----+------+
             |testmachine1|  |testmachine2|   ........
             +------------+  +------------+


In this case, the beaker server is accessed from test machines
as "http://beaker.localdomain" (= internal URL),
while it is accessed from the user's desktop machines as
"https://www.testlab.com" (= external URL).

Since we can't set external URL, notification e-mail from beaker
contains internal URL like this:

  JobID: 2254 Status: Completed Result: Fail <https://beaker.localdomain/bkr/jobs/2254>

that is not very useful for the user working on his desktop.

It is nice to have a config parameter to set up such an external URL.


With beaker 0.6, tg.url_domain and tg.url_scheme could be used
to setup the external URL.
However, with beaker 0.9, those parameters are used also to
construct internal URL. So we can no longer use them for this purpose.
Comment 1 Bill Peck 2012-07-24 15:15:31 EDT
http://gerrit.beaker-project.org/#/c/1239/
Comment 3 Dan Callaghan 2012-08-09 04:06:59 EDT
Beaker 0.9.2 has been released.
Comment 4 Jun'ichi NOMURA 2012-08-16 02:56:04 EDT
(Sorry, solution is not clear and I'm not very confident about my guess below.
 Please confirm/correct below.)

For the example case in comment#0, we should set:
  tg.url_domain = www.testlab.com
  tg.lab_domain = beaker.localdomain
  tg.url_scheme = https

  (For lab_domain, it's always 'http' regardless tg.url_scheme.)
Comment 5 Dan Callaghan 2012-08-16 18:47:16 EDT
(In reply to comment #4)

That's right.

Note You need to log in before you can comment on or make changes to this bug.