Bug 841777 - [abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
[abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: Xorg server crashed
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
abrt_hash:18fb0ea120849b284dadc78e721...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 04:53 EDT by D. Charles Pyle
Modified: 2012-10-18 17:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 17:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: usr_share_xorg_conf_d.tar.gz (1.55 KB, text/plain)
2012-07-20 04:53 EDT, D. Charles Pyle
no flags Details
File: Xorg.0.log (60.84 KB, text/plain)
2012-07-20 04:53 EDT, D. Charles Pyle
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (569 bytes, text/plain)
2012-07-20 04:53 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2012-07-20 04:53:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
comment:        Cheese was sucking up CPU cycles and leaking memory like a sieve. Then, Cheese crashes and took the X server with it.
event_log:      2012-07-20-02:52:03> Smolt profile successfully saved
executable:     /usr/bin/Xorg
kernel:         3.4.4-5.fc17.x86_64
time:           Fri 20 Jul 2012 02:41:37 AM MDT

Xorg.0.log:     Text file, 62300 bytes
etc_X11_xorg_conf_d.tar.gz: Binary file, 569 bytes
usr_share_xorg_conf_d.tar.gz: Binary file, 1588 bytes

backtrace:
:0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x4650a6]
:1: /usr/bin/Xorg (mieqEnqueue+0x26b) [0x55111b]
:2: /usr/bin/Xorg (0x400000+0x48062) [0x448062]
:3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f3292a0a000+0x60e4) [0x7f3292a100e4]
:4: /usr/bin/Xorg (0x400000+0x80557) [0x480557]
:5: /usr/bin/Xorg (0x400000+0xa4730) [0x4a4730]
:6: /lib64/libpthread.so.0 (0x331d200000+0xefe0) [0x331d20efe0]
:7: /usr/bin/Xorg (0x400000+0x6a950) [0x46a950]
:8: /lib64/libpthread.so.0 (0x331d200000+0xefe0) [0x331d20efe0]
:9: /usr/bin/Xorg (0x400000+0xc00e0) [0x4c00e0]
:10: /usr/bin/Xorg (0x400000+0xfdf6b) [0x4fdf6b]
:11: /usr/bin/Xorg (FreeCursor+0x49) [0x428cf9]
:12: /usr/bin/Xorg (0x400000+0x55242) [0x455242]
:13: /usr/bin/Xorg (FreeClientResources+0x95) [0x456045]
:14: /usr/bin/Xorg (CloseDownClient+0x5a) [0x43388a]
:15: /usr/bin/Xorg (0x400000+0x34466) [0x434466]
:16: /usr/bin/Xorg (0x400000+0x23485) [0x423485]
:17: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x331c621735]
:18: /usr/bin/Xorg (0x400000+0x2375d) [0x42375d]

smolt_data:
:
:
:General
:=================================
:UUID: 983de9fb-8837-45d2-b057-351d6f8b2d46
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6384.44
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E6700  @ 3.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 3203
:System Memory: 3954
:System Swap: 6015
:Vendor: Dell Inc.
:System: Inspiron 560 00
:Form factor: Desktop
:Kernel: 3.4.4-5.fc17.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:14902:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14916:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 3
:(32902:14882:4136:1081) pci, ahci, STORAGE, 82801JI (ICH10 Family) SATA AHCI Controller
:(32902:14912:4136:1081) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14870:4136:1081) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
:(4098:26814:4163:824) pci, fglrx_pci, VIDEO, Juniper [Radeon HD 5750 Series]
:(5361:23418:112:29764) pci, cx18, MULTIMEDIA_VIDEO, WinTV HVR-1600
:(32902:14910:4136:1081) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14901:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:14896:4136:1081) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:9294:4136:1081) pci, None, PCI/PCI, 82801 PCI Bridge
:(4332:33128:4136:1081) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:14900:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(32902:14903:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14904:4136:1081) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:(32902:11808:4136:1081) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4136:1081) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(4098:43608:4163:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(32902:14906:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4136:1081) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_illuminatus--1-lv_root / ext4 4096 4096 12818881 6745613 6103361 3211264 2589554 2589554
:/dev/sdb5 /boot ext4 1024 1024 508644 377274 351674 128016 127639 127639
:/dev/mapper/vg_illuminatus--1-lv_home /home ext4 4096 4096 6404571 4109132 3788006 1605632 1554657 1554657
:

xorg.conf:
:Section "ServerLayout"
:	Identifier     "aticonfig Layout"
:	Screen      0  "aticonfig-Screen[0]-0" 0 0
:EndSection
:
:Section "Module"
:EndSection
:
:Section "Monitor"
:	Identifier   "aticonfig-Monitor[0]-0"
:	Option	    "VendorName" "ATI Proprietary Driver"
:	Option	    "ModelName" "Generic Autodetecting Monitor"
:	Option	    "DPMS" "true"
:EndSection
:
:Section "Device"
:	Identifier  "aticonfig-Device[0]-0"
:	Driver      "fglrx"
:	BusID       "PCI:1:0:0"
:	Option      "AllowGLXWithComposite" "true"
:	Option      "AddARGBGLXVisuals" "true"
:	Option      "TripleBuffer" "true"
:	Option      "SWCursor" "false"
:EndSection
:
:Section "Screen"
:	Identifier "aticonfig-Screen[0]-0"
:	Device     "aticonfig-Device[0]-0"
:	Monitor    "aticonfig-Monitor[0]-0"
:	DefaultDepth     24
:	SubSection "Display"
:		Viewport   0 0
:		Depth     24
:	EndSubSection
:EndSection
:
Comment 1 D. Charles Pyle 2012-07-20 04:53:15 EDT
Created attachment 599334 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 2 D. Charles Pyle 2012-07-20 04:53:16 EDT
Created attachment 599335 [details]
File: Xorg.0.log
Comment 3 D. Charles Pyle 2012-07-20 04:53:18 EDT
Created attachment 599336 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 4 D. Charles Pyle 2012-08-04 14:12:49 EDT
I have found the potential culprit for this error and related errors. This has occurred since Fedora 17. I do not yet know precisely why or where this is happening, but I suspect it may possibly have something to do with recent changes to filesystem layout in Fedora 17 (/lib/firmware -> /usr/lib/firmware with a symbolic link). The culprit involves the cx18 and cx18_alsa modules with a Hauppauge WinTV HVR-1600 tuner/video capture card.

The problem only occurs when the three related firmware files are in /usr/lib/firmware directory. The problem does not occur when the firmware files are located in that directory.

Cheese also fails to run, as is the case for User Accounts (gnome-control-center user-accounts), both of which problems cause the crashes that lead up to the xorg server crashes.

High CPU usage up to 100% occurs, as well as memory being filled and heavy swapping occurring, while frequent soft lock-ups occur during this event. After about five minutes or so the applications will crash by being killed by the system.

If the firmware files are removed from the directory, the crashes cease and both User Accounts (gnome-control-center user-accounts) and Cheese function as intended. Unfortunately, this results in the video capture/tuner card not functioning properly.
Comment 5 Adam Jackson 2012-10-18 17:39:59 EDT
fglrx, notourbug

Note You need to log in before you can comment on or make changes to this bug.