Bug 841798 - don't wrap plugins with the same arch
don't wrap plugins with the same arch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 05:12 EDT by Dagmar Prokopová
Modified: 2014-07-01 18:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 10:21:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dagmar Prokopová 2012-07-20 05:12:39 EDT
Description of problem:

When nspuginwrapper is installed along with adobe flashplayer (according to [1]) attempt to open an RHU course makes flash freeze.

Version-Release number of selected component (if applicable):

flash-plugin-11.2.202.236-release.x86_64
nspluginwrapper-1.4.4-9.fc17.x86_64
firefox-13.0.1-1.fc17.x86_64


How reproducible: always


Steps to Reproduce:

try to open RHU course ENG110 or most probably any other one
  
Actual results:

flash freezes:

[root@fedora ~]# type=ANOM_ABEND msg=audit(1342704916.998:247): auid=1000 uid=1000 gid=1000 ses=2 subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 pid=10910 comm="npviewer.bin" reason="memory violation" sig=5
    Jul 19 15:35:16 fedora kernel: [23208.447154] npviewer.bin[10910] trap int3 ip:3e03e4e851 sp:7fffe1e43c00 error:0
    Jul 19 15:35:17 fedora abrtd: Directory 'ccpp-2012-07-19-15:35:17-10910' creation detected
    Jul 19 15:35:17 fedora abrt[10930]: Saved core dump of pid 10910 (/usr/lib64/nspluginwrapper/npviewer.bin) to /var/spool/abrt/ccpp-2012-07-19-15:35:17-10910 (78196736 bytes)
    Jul 19 15:35:17 fedora abrtd: Blacklisted package 'nspluginwrapper'
    Jul 19 15:35:17 fedora abrtd: 'post-create' on '/var/spool/abrt/ccpp-2012-07-19-15:35:17-10910' exited with 1
    Jul 19 15:35:17 fedora abrtd: Corrupted or bad directory /var/spool/abrt/ccpp-2012-07-19-15:35:17-10910, deleting 


Expected results:

flash doesn't freeze

Workaround:

This can be worked around by uninstalling nspluginwrapper or by mentioning flash in /etc/sysconfig/nspluginwrapper

Suggested fix:

Append *flash* to IGNORE_WRAP in /etc/sysconfig/nspluginwrapper

Additionally also please update [1] as nspluginwrapper is no more needed for flash plugin to work.


------------------------
[1] http://fedoraproject.org/wiki/Flash
Comment 1 Martin Stransky 2012-07-20 06:39:31 EDT
Can you try to run nspluginwrapper/flash with disabled selinux? (#setenforce 0)
Comment 2 Dagmar Prokopová 2012-07-20 12:31:07 EDT
(In reply to comment #1)
> Can you try to run nspluginwrapper/flash with disabled selinux? (#setenforce
> 0)

I disabled selinux, but no change has occured. It still freezes.
Comment 3 Martin Stransky 2012-07-23 04:34:43 EDT
We may disable the flash wrap for the same arch only, the cross arch wrapping is still used. But nspluginwrapper does not have such feature yet...or we may disable the same arch wrapping anyway because all plugins are run as OOP in plugin-container by default.
Comment 4 Martin Stransky 2012-08-13 10:21:08 EDT
Added to rawhide.

Note You need to log in before you can comment on or make changes to this bug.