Bug 84187 - Segmentation fault when erasing old kernel
Segmentation fault when erasing old kernel
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-13 02:34 EST by Stephen Rasku
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-07 19:46:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (393.62 KB, text/plain)
2003-03-28 17:40 EST, Stephen Rasku
no flags Details
rpm output (2.35 KB, text/plain)
2003-03-28 17:41 EST, Stephen Rasku
no flags Details

  None (edit)
Description Stephen Rasku 2003-02-13 02:34:12 EST
Description of problem:

I get a segmentation fault when I try and remove an old kernel.  I do not get a
core.

Version-Release number of selected component (if applicable):
rpm-4.0.4-7x.18
kernel-2.4.18-24.7.x
glibc-2.3.1-43
glibc-common-2.3.1-43
glibc-devel-2.3.1-43

How reproducible:

All the time.

Steps to Reproduce:

As root:
1.rpm -e kernel-2.4.18-18.7.x.
    
Actual results:

Segmentation fault

Expected results:

Old kernel should be removed.
Comment 1 Jeff Johnson 2003-02-13 10:39:48 EST
A "rpm --rebuilddb" with rpm-4.1 should fix your problem.

Otherwise, please reopen this bug, and give me a pointer
(i.e. URL, attachments won't work) to a tarball of your
database
    cd /var/lib
    tar czvf /tmp/rpmdb-84187.tar.gz rpm
Comment 2 Stephen Rasku 2003-02-13 13:34:07 EST
This is turning into a dependency nightmare.  I have downloaded the following RPMs:

gnome-python2-1.99.11-8.i386.rpm         rhnlib-1.0-1.noarch.rpm
gnome-python2-canvas-1.99.11-8.i386.rpm  rhpl-0.51-1.i386.rpm
kdeadmin-3.0.3-3.i386.rpm                rpm-4.1-1.06.i386.rpm
libelf-0.8.2-2.i386.rpm                  rpm-build-4.1-1.06.i386.rpm
popt-1.7-1.06.i386.rpm                   rpm-python-4.1-1.06.i386.rpm
python-2.2.1-17.i386.rpm                 up2date-3.0.7-1.i386.rpm
rhn-applet-2.0.0-28.i386.rpm             up2date-gnome-3.0.7-1.i386.rpm


But I still have the following failed dependencies:
        gnome-python2-bonobo is needed by gnome-python2-1.99.11-8
        libart_lgpl_2.so.2   is needed by gnome-python2-1.99.11-8
        libbonobo-2.so.0   is needed by gnome-python2-1.99.11-8
        libbonobo-activation.so.4   is needed by gnome-python2-1.99.11-8
        libbonoboui-2.so.0   is needed by gnome-python2-1.99.11-8
        libgconf-2.so.4   is needed by gnome-python2-1.99.11-8
        libgnome-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomecanvas-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomeui-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomevfs-2.so.0   is needed by gnome-python2-1.99.11-8
        liblinc.so.1   is needed by gnome-python2-1.99.11-8
        libORBit-2.so.0   is needed by gnome-python2-1.99.11-8
        libgnomecanvas >= 2.0.0 is needed by gnome-python2-canvas-1.99.11-8
        pygtk2 >= 1.99.11 is needed by gnome-python2-canvas-1.99.11-8
        libart_lgpl_2.so.2   is needed by gnome-python2-canvas-1.99.11-8
        libgnomecanvas-2.so.0   is needed by gnome-python2-canvas-1.99.11-8
        pygtk2 >= 1.99.12-6 is needed by rhn-applet-2.0.0-28
        libgnomeui >= 2.0.3-1 is needed by rhn-applet-2.0.0-28
        libgnome >= 2.0.2-5 is needed by rhn-applet-2.0.0-28
        gnome-python2-gtkhtml2 is needed by rhn-applet-2.0.0-28
        libart_lgpl_2.so.2   is needed by rhn-applet-2.0.0-28
        libbonobo-2.so.0   is needed by rhn-applet-2.0.0-28
        libbonobo-activation.so.4   is needed by rhn-applet-2.0.0-28
        libbonoboui-2.so.0   is needed by rhn-applet-2.0.0-28
        libgconf-2.so.4   is needed by rhn-applet-2.0.0-28
        libgnome-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomecanvas-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomeui-2.so.0   is needed by rhn-applet-2.0.0-28
        libgnomevfs-2.so.0   is needed by rhn-applet-2.0.0-28
        liblinc.so.1   is needed by rhn-applet-2.0.0-28
        libORBit-2.so.0   is needed by rhn-applet-2.0.0-28
        librpm-4.0.4.so   is needed by gnorpm-0.96-14
        librpm-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmdb-4.0.4.so   is needed by gnorpm-0.96-14
        librpmdb-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0
        librpmio-4.0.4.so   is needed by gnorpm-0.96-14
        librpmio-4.0.4.so   is needed by ucd-snmp-4.2.5-7.73.0

I don't want to upgrade my whole system just to get rpm-4.1.  I have rebuilt the
database with rpm-4.0.4 and I have put the tar file you requested at:

http://richmond.tgivan.com/rpmdb-84187.tar.gz

The md5sum is:

3bb4d5360ad0bd1f80b3affaaafb7f92  rpmdb-84187.tar.gz

I don't know if that helps you or not.

Comment 3 Jeff Johnson 2003-02-20 12:01:03 EST
There's nothing wrong with your database, so something
else is going on.

Are you using LDAP passwords? If so, then you need to
run nscd to avoid a segfault with statically linked
executables like /bin/rpm.

Can you upgrade/erase/install other packages?

Do other rpm commands "work"?

SOme other (i.e. not rpmdb) common factor needs to be identified.
Comment 4 Stephen Rasku 2003-02-21 13:07:30 EST
I am not using LDAP passwords.  I can install packages but I can't upgrade or
erase packages.  I haven't done an exhaustive survey of all the rpm commands
but, of the commands I commonly use, only erase is broken.

If I can build RPM from source I should be able to determine exactly where the
segfault is happening.  However, I want to avoid installing this test RPM over
the current rpm binary.  Can you give me a source RPM that turns debugging on
and installs to another location?  If you build a source RPM, does it keep the
build tree or does it remove it?
Comment 5 Stephen Rasku 2003-02-21 13:08:59 EST
Another thing.  I just upgraded the shadow-utils package using up2date.  I don't
know how this works if rpm isn't working.
Comment 6 Jeff Johnson 2003-02-24 19:10:40 EST
I still need some hint other than rpmdb to attempt
to reproduce this problem.

I don't have a src rpm with debugging symbols. There
are symbols aavailable by doing
    cd /usr/src/redhat/BUILD/rpm-4.2
    make install
after rebuilding. Otherwise, -vv output is often
enough to characterize a problem.
Comment 7 Stephen Rasku 2003-03-28 17:40:30 EST
Created attachment 90774 [details]
strace output

I took a hint from bug 86047 and am attaching the strace file from:

    strace -o /tmp/strace.out rpm -evv kernel-2.4.18-18.7.x

I will attach the output from rpm in a separate attachment.
Comment 8 Stephen Rasku 2003-03-28 17:41:04 EST
Created attachment 90775 [details]
rpm output
Comment 9 Stephen Rasku 2003-09-07 19:46:38 EDT
This was apparently fixed by the fix for bug 86047.

Note You need to log in before you can comment on or make changes to this bug.