Bug 841899 - bacula: Please compile with capabilities support
bacula: Please compile with capabilities support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 09:52 EDT by Florian Weimer
Modified: 2012-07-23 08:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 08:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2012-07-20 09:52:51 EDT
Bacula does not compile/link to libcap, so the -k option is not supported:

# bacula-fd -k -u bacula -f
18-Jun 12:55 bacula-fd: ERROR TERMINATION at priv.c:131
Keep readall caps not implemented this OS or missing libraries.
#

Running the file daemon with -k might be a good option if you don't need restore functionality.
Comment 1 Simone Caronni 2012-07-20 13:07:37 EDT
Hello,

ReadAll Capabilities support has been enabled by default in Fedora 15+. This, however, has the side effect of disabling backups of extended attributes because this requires super user privileges. There's a note in the sysconfig file for Fedora 17, I will make the change also in Fedora 16.

You should see that the correct libraries are linked into the binary:

 $ ldd /usr/sbin/bacula-fd  | grep cap
 libcap.so.2 => /lib64/libcap.so.2 (0x0000003223e00000)

I'm on RHEL and Fedora 17 systems at the moment so I cannot test what's the problem here, can you perform the following?

1) Launching the daemon this way, and paste the output here:

 # bacula-fd -k -u bacula -f -d 200

2) Update the bacula file daemon to version 5.2.10 on a box that has the client only and try again to launch it with the "-k" flag, so we can check if it's a problem in 5.0.3.

You can find a precompiled binary here:

http://repos.fedorapeople.org/repos/slaanesh/bacula/

Please execute the following:

 # wget http://repos.fedorapeople.org/repos/slaanesh/bacula/fedora-bacula.repo \
        -O /etc/yum.repos.d/fedora-bacula.repo
 # yum update bacula*
 # bacula-fd -k -u bacula -f -d 200

To revert back to the Fedora 16 version, simply execute the following:

 # rm -f /etc/yum.repos.d/fedora-bacula.repo
 # yum distro-sync bacula*

Thanks,
--Simone
Comment 2 Florian Weimer 2012-07-23 08:03:19 EDT
(In reply to comment #1)
> I'm on RHEL and Fedora 17 systems at the moment so I cannot test what's the
> problem here, can you perform the following?

Sorry, it turns out that I misinterpreted my notes.  The functionality is clearly present in the Fedora 16 package.

Note You need to log in before you can comment on or make changes to this bug.