Bug 841911 - dhclient does not set the IP address
dhclient does not set the IP address
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp (Show other bugs)
5.8
i386 Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 10:24 EDT by Diana Chinces
Modified: 2012-07-23 09:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 09:02:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diana Chinces 2012-07-20 10:24:36 EDT
Description of problem:
Running dhclient from rhel 5.8 stage2 does  not set the IP Address on the interface. It shows in the output that it has bounded to an IP address but that is not set on the interface.

Version-Release number of selected component (if applicable):
3.0.5

How reproducible:


Steps to Reproduce:
1. Boot a RHEL 5.8 server in the pre installation environment
2. Run dhclient interface_name
  
Actual results:

the ip address to which it has bounded is not set on the interface

Expected results:

the ip address to be set on the interface

Additional info:
Comment 1 Jiri Popelka 2012-07-20 11:23:21 EDT
(In reply to comment #0)
> Expected results:
> the ip address to be set on the interface

dhclient adds the address to interface in /sbin/dhclient-script in dhconfig() function. You can add a 'set -x' as a first line in the dhconfig() function. That could help us get more info of what's been wrong.
Comment 2 Diana Chinces 2012-07-20 12:02:34 EDT
We do not have /sbin/dhclient-script . We are in the pre installation environment using a ISO to load the initrd and stage2 images and there we are trying to run dhclient
Comment 3 Diana Chinces 2012-07-20 12:19:40 EDT
Found the issue. We needed to call pump as well for the interface
Comment 4 Jiri Popelka 2012-07-23 06:38:46 EDT
(In reply to comment #3)
> Found the issue. We needed to call pump as well for the interface

Does that mean that we can close this ticket ?
Comment 5 Diana Chinces 2012-07-23 08:56:55 EDT
Yes. Thanks

Note You need to log in before you can comment on or make changes to this bug.