Bug 841975 - [RFE] support url method for deleteing a systems pxe record
[RFE] support url method for deleteing a systems pxe record
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.2
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-20 13:56 EDT by Bill Peck
Modified: 2012-08-09 04:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2012-07-20 13:56:14 EDT
Description of problem:
Currently we only support xmlrpc for deleting a systems pxe record.  To support RHEVH installs automatically we need to be able to do this via a simple wget or curl action.

Version-Release number of selected component (if applicable):
0.9.1
Comment 1 Bill Peck 2012-07-20 15:51:12 EDT
I came up with a hack that works.  Will have to see if there is a nicer way to implement it though.
Comment 2 Bill Peck 2012-07-24 09:55:11 EDT
http://gerrit.beaker-project.org/#/c/1236/
Comment 3 Dan Callaghan 2012-08-03 02:26:58 EDT
Looks like this still needs merging -> setting back to MODIFIED.
Comment 4 Bill Peck 2012-08-03 11:22:02 EDT
really merged now
Comment 5 Dan Callaghan 2012-08-07 01:38:39 EDT
All recent jobs on stage have been using this and it works -> VERIFIED.
Comment 6 Dan Callaghan 2012-08-09 04:06:47 EDT
Beaker 0.9.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.