Bug 842020 - what is rhsmcertd --help-rhsmcertd?
what is rhsmcertd --help-rhsmcertd?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-20 17:52 EDT by John Sefler
Modified: 2013-01-07 22:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:57:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-20 17:52:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.10-1.git.2.fec0032.el5


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel59 ~]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                      Show help options
  --help-all                      Show all help options
  --help-rhsmcertd                rhsmcertd

Application Options:
  -c, --cert-interval=MINUTES     Interval to run cert check (in minutes)
  -i, --heal-interval=MINUTES     Interval to run healing (in minutes)
  -n, --now                       Run the initial checks immediatly, with no delay.
  -d, --debug                     Show debug messages

[root@jsefler-rhel59 ~]# rhsmcertd --help-rhsmcertd
Usage:
  rhsmcertd [OPTION...] 



[root@jsefler-rhel59 ~]# 
  


^^^ WHAT IS THE --help-rhsmcertd HELP OPTION SUPPOSED TO SHOW?  CURRENTLY IT SHOWS NOTHING.  IF THERE IS NOTHING TO SHOW, THEN IS THERE A REASON TO HAVE --help-all AND --help-rhsmcertd OPTIONS?
Comment 1 Bryan Kearney 2012-08-24 10:15:35 EDT
fixed in master at 85087cd1e4d109901b8098ca4135dd6165e28132
Comment 2 RHEL Product and Program Management 2012-08-24 10:18:48 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Shwetha Kallesh 2012-09-03 08:28:29 EDT
Marking verified!!

RPM used:
[root@unused pki]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-migration-1.0.17-1.el5
subscription-manager-migration-data-1.11-1.el5
subscription-manager-debuginfo-1.0.17-1.el5


[root@unused pki]# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -?, --help                      Show help options

Application Options:
  -c, --cert-interval=MINUTES     Interval to run cert check (in minutes)
  -i, --heal-interval=MINUTES     Interval to run healing (in minutes)
  -n, --now                       Run the initial checks immediatly, with no delay.
  -d, --debug                     Show debug messages
Comment 6 errata-xmlrpc 2013-01-07 22:57:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.