Bug 842045 - [abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: FindInterestedChildren: Process /usr/bin/Xorg was killed by signal 11 (SIGSEGV)
[abrt] xorg-x11-server-Xorg-1.12.2-4.fc17: FindInterestedChildren: Process /u...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
abrt_hash:8f18b5d1ca4a9a73af66a79fc66...
:
: 842391 865136 868393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-21 05:02 EDT by Raphos
Modified: 2014-09-13 15:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 17:27:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (21.99 KB, text/plain)
2012-07-21 05:02 EDT, Raphos
no flags Details
File: backtrace (12.85 KB, text/plain)
2012-07-21 05:02 EDT, Raphos
no flags Details

  None (edit)
Description Raphos 2012-07-21 05:02:34 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/Xorg :0 -background none -logverbose 7 -auth /var/run/gdm/auth-for-gdm-PotvcQ/database -seat seat0 -nolisten tcp vt1
crash_function: FindInterestedChildren
executable:     /usr/bin/Xorg
kernel:         3.4.5-2.fc17.x86_64
pid:            776
pwd:            /var/gdm
time:           sam. 21 juil. 2012 09:14:55 CEST
uid:            0
username:       root

backtrace:      Text file, 13162 bytes
maps:           Text file, 22516 bytes

build_ids:
:fc13956ed359736e6a145d384f112723fd62f20d
:59d79f5efd38cd9fac07f69defc833288d88d9ef
:f69712fe393313f44607679e934bf5a67f39ec50
:faca16f15d87b83d2947a386e319b02f724dcbb5
:6086bff484a49cc8b80cb714d7e83a6391394800
:d64204227cac89018c37b9fa731ce3e3dfac414a
:f227cfd2550b8b9e1a725173e990f88be82dcb3a
:1f9a855d27db1cec175da7330122a83df4b887b3
:fffb0e6dd2f8decf1f14d81c35f1ec36182ae915
:6416c64fde1d567429c32475ee874558589d305a
:3a9b6eb6c75eaceeed3a3765743efa5f7bec2f68
:02db68322dfc216e5403a39891cfcc2e1935f94a
:e45258c755689bf1d66580f1c9a3f9d4d3f26235
:b972156774e528344ecbe3debd19042f612da059
:5ffd7826c0daece3a4ef687af6478f1592847baa
:226a78980343d94a4f9962f8014603f608a0266c
:a3819431cec79ddbe554c22e2800b181a793c4ac
:f4c064df8745dff15466d705fb049138f9a5c949
:8e9fda0d5876e4b614c9b10b6282d9f32351072c
:6668de624a10d486a3484d5b4921f87b1e77d36c
:bc7a0d08f94757b7d157f6dbdc21f2c11fff0846
:a7e2e684a275fb2117fd6c7d6c3c5165eee40ab3
:fb86c3a448f22bd68843d5aa0b35e74d20629e85
:9780659a439a861c2ab9ee197f0f846a9d8810fe
:67792c148d2b8f13f6732c9367e926c26d7376c5
:fd57d5acbcefd8599a3ac31468040d0c9c4cfec1
:c4ec0971b2dcee71aaf8374975474054245fea00
:00ab653044d47d504dd49135aff0306483c4c103
:da1d3a332c8123d472e300a12d6e095009dd7f33
:822e9b3523e8312240f41a25722d539bc77ed436
:7231f4ebd1fadeddbfd0f132032dd172a45dacf5
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:7c35310fc506498c612d5d982ab03becc4b4817c
:31eec8ef031eebabbf04bc18db276f14c74b03cf
:5c4b62956d54145b4bf24dbff070ab951e9a0419
:cd205ab290c2a86dedcf0492b4ed3b4fac88828e
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:9672c6b5fcf8ec125c4048b1b96638856302c263
:13718b5000238cc2421cc0ad9d3ba8a6e6bf8a00
:6088efab2ef3571c51fb041bb70b4ab626221ba4
:fe17d44cdaad04cafc64928ba5b68827e01ec47a
:247132297f287226a24c12e683292f5c94013066
:516204cfc31148538d56b21e2f1b945ed50127d4

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/system/prefdm.service
:2:cpuset:/
:1:name=systemd:/system/prefdm.service

core_backtrace:
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x105738 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x105766 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x105766 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x105766 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x109c60 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x111fd6 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x11294e XIChangeDeviceProperty [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x2d78f DisableDevice [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x2d9f8 RemoveDevice [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x8fa22 DeleteInputDeviceRequest [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x2957c - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x2a011 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x68cc8 - [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x68ed5 FatalError [exe] -
:59d79f5efd38cd9fac07f69defc833288d88d9ef 0x6a0be - [exe] -

dso_list:
:/usr/lib64/xorg/modules/drivers/fbdev_drv.so xorg-x11-drv-fbdev-0.4.2-8.fc17.x86_64 (Fedora Project) 1338422046
:/usr/lib64/xorg/modules/extensions/libextmod.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/extensions/librecord.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/libfb.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/extensions/libdri.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/libmtdev.so.1.0.0 mtdev-1.1.0-3.20110105.fc17.x86_64 (Fedora Project) 1338421110
:/usr/lib64/xorg/modules/drivers/nouveau_drv.so xorg-x11-drv-nouveau-1:0.0.16-37.20120306gitf5d1cd2.fc17.x86_64 (Fedora Project) 1339759429
:/usr/lib64/xorg/modules/input/evdev_drv.so xorg-x11-drv-evdev-2.7.0-2.fc17.x86_64 (Fedora Project) 1338422045
:/usr/lib64/libnss_files-2.15.so glibc-2.15-51.fc17.x86_64 (Fedora Project) 1342782620
:/usr/lib64/xorg/modules/extensions/libdbe.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/dri/nouveau_dri.so mesa-dri-drivers-8.0.3-3.fc17.x86_64 (Fedora Project) 1341036814
:/usr/lib64/xorg/modules/libshadowfb.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/libfbdevhw.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/llvm/libLLVM-3.0.so llvm-libs-3.0-13.fc17.x86_64 (Fedora Project) 1338421107
:/usr/lib64/xorg/modules/extensions/libdri2.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/libexa.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811
:/usr/lib64/xorg/modules/drivers/vesa_drv.so xorg-x11-drv-vesa-2.3.1-1.fc17.x86_64 (Fedora Project) 1338422046
:/usr/lib64/libdrm_nouveau.so.1.0.0 libdrm-2.4.33-3.fc17.x86_64 (Fedora Project) 1338421240
:/usr/lib64/xorg/modules/extensions/libglx.so xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64 (Fedora Project) 1341036811

environ:
:HOSTNAME=raph.home
:HISTSIZE=1000
:QT_GRAPHICSSYSTEM_CHECKED=1
:QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
:KEYTABLE=fr-latin9
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:BOOT_IMAGE=/vmlinuz-3.4.5-2.fc17.x86_64
:NXDIR=/usr/NX
:SYSFONT=True
:LANG=fr_FR.UTF-8
:DISPLAY==:0
:MAIL=/var/spool/mail/root
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SHLVL=0
:PWD=/
:HISTCONTROL=ignoredups
:USER=root
:PATH=/usr/NX/bin:/usr/local/sbin:/sbin:/usr/sbin:/bin:/usr/bin
:LOGNAME=root

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             95837                95837                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       95837                95837                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/var/log/Xorg.0.log
:pos:	59330
:flags:	0100001

var_log_messages:
:Jul 19 10:38:52 raph abrt[3049]: Saved core dump of pid 810 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-2012-07-19-10:38:51-810 (72114176 bytes)
:Jul 21 09:14:55 raph abrt[10906]: File '/usr/bin/Xorg' seems to be deleted
:Jul 21 09:14:55 raph abrt[10906]: Saved core dump of pid 776 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-2012-07-21-09:14:55-776 (55685120 bytes)
Comment 1 Raphos 2012-07-21 05:02:39 EDT
Created attachment 599509 [details]
File: maps
Comment 2 Raphos 2012-07-21 05:02:42 EDT
Created attachment 599510 [details]
File: backtrace
Comment 3 Peter Hutterer 2012-10-22 20:01:47 EDT
have you been able to reproduce this with the latest package versions? and if so, can you please attach the Xorg.log file. Thanks
Comment 4 Peter Hutterer 2012-10-22 20:03:31 EDT
*** Bug 842391 has been marked as a duplicate of this bug. ***
Comment 5 Peter Hutterer 2012-10-22 21:54:04 EDT
*** Bug 865136 has been marked as a duplicate of this bug. ***
Comment 6 Peter Hutterer 2012-10-22 21:55:10 EDT
*** Bug 868393 has been marked as a duplicate of this bug. ***
Comment 7 DeepPurpleFedora 2012-10-23 23:13:01 EDT
I turned on my laptop and started kde. after yakuake startedup (automatically) and it restored dolphin, i got the crash popup, but I can not see any affects (but I am no expert).

Package: xorg-x11-server-Xorg-1.12.3-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Guido 2012-12-30 13:58:30 EST
I confirm DeepPurpleFedora observation of crash popup with KDE using Fedora 18 beta. The xorg-x11-server has aborted, but, runs normally until you exit X. Then the keyboard, mouse, & screen drivers are nonfunctional. On manual reboot, the only way, all is normal unti you try to quit X.

I see this behavior now with any window manager, kwin,fvwm, fluxbox, etc.
Comment 9 Peter Hutterer 2013-01-29 02:37:19 EST
fwiw, while we need to fix the input device shutdown path, the reason this path is triggered here is because of a segfault elsewhere 

#17 0x0000003006e34c24 in rasterize_edges_8 (b=<optimized out>, t=<optimized out>, r=0x7fff1d7abd00, l=0x7fff1d7abcd0, image=<optimized out>) at pixman-edge.c:210
Comment 10 Guido 2013-01-29 11:49:36 EST
I reported this bug during F18 beta testing. It was fixed in the F18 final release. I think this thread should be marked as closed.
Comment 11 Peter Hutterer 2013-01-29 17:27:07 EST
ok, closing as WORKSFORME for now. please re-open if this problem reappears, I'll fix the input device shutdown path upstream.
Comment 12 Peter Hutterer 2013-01-29 17:39:04 EST
ok, closing as WORKSFORME for now. please re-open if this problem reappears, I'll fix the input device shutdown path upstream.

Note You need to log in before you can comment on or make changes to this bug.