Bug 842092 - libimobiledevice does not build with Cython 0.16
libimobiledevice does not build with Cython 0.16
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libimobiledevice (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-21 18:02 EDT by Alan Hamilton
Modified: 2013-04-13 04:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-13 04:27:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes the build (10.82 KB, patch)
2012-08-10 06:30 EDT, Christophe Fergeau
no flags Details | Diff

  None (edit)
Description Alan Hamilton 2012-07-21 18:02:29 EDT
Description of problem:
Attempting to build the SRPM of libimobiledevice fails with
Error: Cython version >= 0.13.0 is required.  You have Cython version 0.16.  You should look at http://www.cython.org

Version-Release number of selected component (if applicable):
Cython-0.16-1.fc17.x86_64
libimobiledevice-1.1.4-1.fc17.x86_64

How reproducible:
Always, with the above packages. The previous release of Cython, Cython.x86_64 0:0.15.1-2.fc17, works

Additional info:
There's an upstream bug entry for this for libimobiledevice: http://libiphone.lighthouseapp.com/projects/27916/tickets/264-error-compiling-with-cython-016_rc0

The problem is an error in parsing the version string for Cython. It fails on versions that are not in the form ##.##.## . A patch is available at http://cgit.sukimashita.com/libimobiledevice.git/commit/?id=70dfe8ad1766990386f1db04bbe5a4826bcde4e5

This patch resolves the version number error, but the package still fails to compile:

Error compiling Cython file:
------------------------------------------------------------
...
        except Exception, e:
            if remapping != NULL:
                plist.plist_free(remapping)
            raise
    
    cdef inline int16_t _send(self, plist.plist_t node):
        ^
------------------------------------------------------------

mobilesync.pxi:152:9: Overriding final methods is not allowed

I'm not aware of any patches for this issue.
Comment 1 Christophe Fergeau 2012-08-10 06:19:41 EDT
http://cgit.sukimashita.com/libimobiledevice.git/commit/?id=84235e0834e57551028329723f4510e1dbe7bc11 should do the trick (testing it now)
Comment 2 Christophe Fergeau 2012-08-10 06:30:54 EDT
Created attachment 603464 [details]
fixes the build

This patch fixes the package build on koji, but I don't have commit access to libimobiledevice so can't push it.
Comment 3 Rex Dieter 2012-08-10 16:28:54 EDT
I can't extract your patch,


patch -p1 < 'attachment..'
patching file 0001-m4-Fix-parsing-of-artistic-cython-version-strings-to.patch
patch: **** malformed patch at line 54: --- a/0002-cython-Do-not-override-final-methods-as-comply-to-Cy.patch
Comment 4 Christophe Fergeau 2012-08-10 17:10:27 EDT
Try with git am maybe
Comment 5 Christophe Fergeau 2012-08-10 17:13:28 EDT
The patch only adds the 3 patches committed on 2012-05-17 from http://cgit.sukimashita.com/libimobiledevice.git/log/ and adds various BuildRequires to be able to run autoreconf -fi after applying the patches. The patches from git apply unchanged on the tarball we have in f18 and rawhide.

Note You need to log in before you can comment on or make changes to this bug.