Bug 842105 - Thunderbird does not handle .docx attached documents.
Thunderbird does not handle .docx attached documents.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 01:19 EDT by Erik P. Olsen
Modified: 2012-07-25 02:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 02:13:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik P. Olsen 2012-07-22 01:19:39 EDT
Description of problem:

Opening an attached document of type .docx produces an error box with the text:

"/tmp/document.docx could not be opened, because the associated helper application does not exist. Change the association in your preferences."

where "document.docx" is any .docx document. However, it can be saved and subsequently opened by LibreOffice Writer.



Version-Release number of selected component (if applicable):

[erik@epohost ~]$ rpm -qa|grep thunderbird
thunderbird-13.0.1-1.fc16.x86_64

How reproducible: Allways


Steps to Reproduce:
1. Receive a mail with attached .docx file
2. Double click on attachment
3.
  
Actual results: Error box with text as detailed above.


Expected results: Document opened with LibreOffice Writer


Additional info: "Thunderbirds Preferences -> Attachments -> Incomming" has a content type of "Microsoft Word Document" with action "Use LibreOffice Writer (default)". Setting the cursor over this content type displays the text:

"Microsoft Word Document (application/vnd.openxmlformats-officedocument.wordprocessingml.document: .docx)"

and there is no way to edit this content type or to add a new.
Comment 1 Jan Horak 2012-07-23 08:45:59 EDT
I cannot reproduce on F17, could you try command: 
xdg-open file.docx
to check if file opens in libreoffice?

It also might be related to content of: ~/.local/share/applications where user installed app launchers are. You may check content of these directory to see if there is some file related to mime type application/vnd.openxmlformats-officedocument.wordprocessingml.document or some libreoffice launcher.
Comment 2 Erik P. Olsen 2012-07-24 11:52:01 EDT
(In reply to comment #1)
> I cannot reproduce on F17, could you try command: 
> xdg-open file.docx
> to check if file opens in libreoffice?

Yes, file.docx opens in libreoffice.
> 
> It also might be related to content of: ~/.local/share/applications where
> user installed app launchers are. You may check content of these directory
> to see if there is some file related to mime type
> application/vnd.openxmlformats-officedocument.wordprocessingml.document or
> some libreoffice launcher.

There is no mention of this mime type in ~/.local/share/applications, however the mime type is repetedly mentioned in the file ~/.local/share/recently-used.xbel
Comment 3 Erik P. Olsen 2012-07-24 14:47:30 EDT
Just tried again to view the attached docx file and - surprise surprise - now it worked! I don't think I've installed or updated anything since Sunday, so it's a mystery that it worked. Maybe it's a Sunday problem :-)

You may close this issue, I can reopen it if it turns up again.
Comment 4 Jan Horak 2012-07-25 02:13:46 EDT
Okay, feel free to reopen if reoccurs.

Note You need to log in before you can comment on or make changes to this bug.