Bug 842110 - Errors trying to run rhc client tools on JRuby
Errors trying to run rhc client tools on JRuby
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Hiro Asari
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 03:11 EDT by Nam Duong
Modified: 2015-05-14 22:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 10:25:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-07-22 03:11:51 EDT
Description of problem:
As per: https://openshift.redhat.com/community/forums/openshift/installing-client-tools-on-win7-wjruby-doesnt-work#comment-22558

C:\Users\Brad.hp-dv73165dx>rhc domain show
LoadError: no such file to load -- jruby_pageant
  require at org/jruby/RubyKernel.java:1033
  require at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36
   (root) at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/gems/1.8/gems/net-ssh-2.5.2/lib/net/ssh/authentic
ation/agent/java_pageant.rb:1
  require at org/jruby/RubyKernel.java:1033
  require at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36
   (root) at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/gems/1.8/gems/net-ssh-2.5.2/lib/net/ssh/authentic
ation/agent/java_pageant.rb:20
  require at org/jruby/RubyKernel.java:1033
  require at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36
   (root) at C:/Users/Brad.hp-dv73165dx/torquebox-2.0.3/jruby/lib/ruby/gems/1.8/gems/net-ssh-2.5.2/lib/net/ssh/authentic
ation/agent.rb:4

Is JRuby supported?
Comment 1 Brad 2012-07-26 01:14:40 EDT
This did not work even after installing the gem jruby-pageant.  Only after installing this jruby-pageant, then un-installing and re-installing the net-ssh gem which requires jruby-pageant, then it worked.  

Since jruby-pageant is required by net-ssh, installing net-ssh should automatically include/install jruby-pageant.
Comment 2 Clayton Coleman 2012-08-13 17:50:32 EDT
I think this is an upstream bug against net-ssh.  They said they fixed this in https://github.com/net-ssh/net-ssh/pull/35 which is 2.4, but you have 2.5.2.  

Not sure what needs to be fixed but Hiro may have an idea.
Comment 3 Hiro Asari 2012-08-13 20:33:18 EDT
I was not aware of this Windows-specific problem. Without access to a Windows machine/VM, I am unable to reproduce or debug it.

The last comment on the thread says re-installing net-ssh fixed the problem. It is not clear, though, how it did. There may be some configuration issue at play, but that's not clear from the comment. Again, without reproduction it is not easy to say.
Comment 4 Ben Browning 2012-08-14 10:02:34 EDT
I was able to reproduce the issue reported on the community thread in a Windows VM. I was then able to resolve the issue in my VM by installing the jruby-pageant gem and did not have to reinstall net-ssh.
Comment 5 Hiro Asari 2012-08-14 10:25:38 EDT
Giving Ben's input, I am marking this ticket as NOTABUG. If we have more reports of the problem with jruby-pageant present (with net-ssh 2.5.2 or similarly recent version), then we can revisit this issue.

Note You need to log in before you can comment on or make changes to this bug.