Bug 842127 - [abrt] evolution-data-server-3.4.3-1.fc17: g_slice_alloc: Process /usr/libexec/evolution-calendar-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.4.3-1.fc17: g_slice_alloc: Process /usr/libexe...
Status: CLOSED DUPLICATE of bug 804297
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:ad114fd4eff8f74ad5a6871e669...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 08:05 EDT by Louis van Dyk
Modified: 2012-07-23 14:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 14:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.64 KB, text/plain)
2012-07-22 08:05 EDT, Louis van Dyk
no flags Details
File: maps (43.76 KB, text/plain)
2012-07-22 08:06 EDT, Louis van Dyk
no flags Details
File: dso_list (8.73 KB, text/plain)
2012-07-22 08:06 EDT, Louis van Dyk
no flags Details

  None (edit)
Description Louis van Dyk 2012-07-22 08:05:51 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
comment:        I opened up evolution, which has an IMAP+ ccount as primary, and an Exchange 2010 account as secondary.  The Exchange account holds my primary calendar.  I opened a meeting invite in the IMAP+ account, which checked the calendar in Exchange, and caused this fault.
crash_function: g_slice_alloc
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.4.4-5.fc17.x86_64
pid:            11438
pwd:            /
time:           Sun 22 Jul 2012 01:30:39 PM SAST
uid:            1000
username:       louis
var_log_messages: Jul 22 13:30:41 fedora abrt[11457]: Saved core dump of pid 11438 (/usr/libexec/evolution-calendar-factory) to /var/spool/abrt/ccpp-2012-07-22-13:30:39-11438 (160899072 bytes)
xsession_errors: 

backtrace:      Text file, 42639 bytes
dso_list:       Text file, 8937 bytes
maps:           Text file, 44810 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/louis/2

core_backtrace:
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6173f g_slice_alloc libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x629f3 g_slist_append libglib-2.0.so.0 -
:01374351e1ef0b8daba92b7a56dc224298f747c0 0x32bf6 - libecal-1.2.so.11 -
:01374351e1ef0b8daba92b7a56dc224298f747c0 0x33834 - libecal-1.2.so.11 -
:01374351e1ef0b8daba92b7a56dc224298f747c0 0x33cce e_cal_component_set_icalcomponent libecal-1.2.so.11 -
:858760438fca57be9b8c9e559ff18e4946f4989f 0x28523 - libedata-cal-1.2.so.15 -
:858760438fca57be9b8c9e559ff18e4946f4989f 0x23393 e_cal_backend_store_load libedata-cal-1.2.so.15 -
:0ac006fc672a6a3efb366448d8f515f39660d4b9 0x10b24 - libecalbackendews.so -
:858760438fca57be9b8c9e559ff18e4946f4989f 0x2b3e7 - libedata-cal-1.2.so.15 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6ab42 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6a345 - libglib-2.0.so.0 -
:6086bff484a49cc8b80cb714d7e83a6391394800 0x7d14 start_thread libpthread.so.0 -
:f69712fe393313f44607679e934bf5a67f39ec50 0xf197d clone libc.so.6 -

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-P10SrEtso5,guid=a5eda7b5b6efa8c99709cffa00000045
:XDG_SESSION_COOKIE=7075619d19a1b86ee0cf10000000000d-1342470403.601143-494216574
:XDG_RUNTIME_DIR=/run/user/louis
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/run/user/louis/keyring-JCoZD7/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2047,unix/unix:/tmp/.ICE-unix/2047
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=louis
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/run/user/louis/keyring-JCoZD7/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-P10SrEtso5,guid=a5eda7b5b6efa8c99709cffa00000045
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-louis-uLTEgE/database
:USER=louis
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=2042
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/louis
:GNOME_KEYRING_CONTROL=/run/user/louis/keyring-JCoZD7
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=louis
:HOME=/home/louis

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31468                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31468                31468                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[2381022]
:pos:	0
:flags:	04002
:7:socket:[2380746]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[2381023]
:pos:	0
:flags:	02004002
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:/home/louis/.cache/evolution/calendar/ews___louisv@bcx.co.za_louisv@bcx.co.za/AAMkAGEzYWYxZDYyLWU1M2ItNDg1OS04MzFhLWIzZmZmYmQ1ZTcxNwAuAAAAAAAyv9CCQACSToMRRiMhrsErAQBGDvgO/2LhRZjcKEajBZGIAAAGljsBAAA=/.#keys.xml
:pos:	719
:flags:	0100001
:13:/home/louis/.cache/evolution/calendar/ews___louisv@bcx.co.za_louisv@bcx.co.za/AAMkAGEzYWYxZDYyLWU1M2ItNDg1OS04MzFhLWIzZmZmYmQ1ZTcxNwAuAAAAAAAyv9CCQACSToMRRiMhrsErAQBGDvgO/2LhRZjcKEajBZGIAAAIPTIaAAA=/.#keys.xml
:pos:	715
:flags:	0100001

smolt_data:
:
:
:General
:=================================
:UUID: a52009f1-d4f3-476f-ac10-feb7dea90149
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 5199.76
:CPU Vendor: GenuineIntel
:CPU Model: Pentium(R) Dual-Core  CPU      E5300  @ 2.60GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2600
:System Memory: 3954
:System Swap: 6015
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.4.4-5.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10168:4163:33145) pci, None, PCI/ISA, P5KPL-VM Motherboard
:(4332:33078:4163:33607) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10202:4163:33145) pci, i801_smbus, SERIAL, P5KPL-VM Motherboard
:(32902:10176:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(32902:10192:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4163:33145) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4163:33663) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10207:4163:33145) pci, ata_piix, STORAGE, P5KPL-VM Motherboard
:(4318:3044:6860:12755) pci, snd_hda_intel, MULTIMEDIA, High Definition Audio Controller
:(32902:9294:4163:33145) pci, None, PCI/PCI, 82801 PCI Bridge
:(4318:3235:6860:12755) pci, nvidia, VIDEO, GT215 [GeForce GT 240]
:(32902:10185:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10184:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10688:4163:33456) pci, None, HOST/PCI, P5KPL-VM Motherboard
:(32902:10186:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10187:4163:33145) pci, uhci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10188:4163:33145) pci, ehci_hcd, USB, P5KPL-VM,P5LD2-VM Mainboard
:(32902:10689:4163:33456) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_fedora-lv_root / ext4 4096 4096 59301645 6971743 4002963 14843904 14201868 14201868
:/dev/sdd1 WITHHELD ext4 4096 4096 243931001 12859017 649517 61054976 60764286 60764286
:/dev/sdb1 WITHHELD ext4 4096 4096 487879867 8111090 3227307 122101760 121874328 121874328
:/dev/sda2 /boot ext4 1024 1024 508644 405153 379553 128016 127754 127754
:/dev/sde1 WITHHELD ext4 4096 4096 121957788 35335822 34114862 30531584 30339111 30339111
:
Comment 1 Louis van Dyk 2012-07-22 08:05:58 EDT
Created attachment 599583 [details]
File: backtrace
Comment 2 Louis van Dyk 2012-07-22 08:06:02 EDT
Created attachment 599584 [details]
File: maps
Comment 3 Louis van Dyk 2012-07-22 08:06:05 EDT
Created attachment 599585 [details]
File: dso_list
Comment 4 Milan Crha 2012-07-23 14:07:33 EDT
Thanks for a bug report. There had been reported a similar bug report already, thus I'm marking it as a duplicate.

Yours is from evolution-ews, while the other is from caldav, thus it seems like a fault in the common place of these.

*** This bug has been marked as a duplicate of bug 804297 ***

Note You need to log in before you can comment on or make changes to this bug.