Bug 842191 - Search and replace doesn't return results with empty translation
Search and replace doesn't return results with empty translation
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.7
Assigned To: David Mason
Ding-Yi Chen
:
: 856423 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 20:21 EDT by Alex Eng
Modified: 2012-11-29 18:29 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20120810-0025)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 18:29:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Eng 2012-07-22 20:21:32 EDT
Description of problem:
Search doesn't return results with empty translation even if source contain the term.


Version-Release number of selected component (if applicable):
1.7

How reproducible:
Always

Steps to Reproduce:
1. Go into a document with multiple rows contain similar string in source. Remove translation in some of them.
2. Go go 'Search and replace' and search for the term.
  
Actual results:
Only return results that contains translation.

Expected results:
Return all results with or without translation.
Comment 1 David Mason 2012-07-26 04:11:33 EDT
This was caused by a specific check for empty translation, which has now been removed.

see:
 - code adjustment to allow fix: https://github.com/zanata/zanata/commit/1af0d67f5b270995b978f246958a21841ee619b1
 - fix: https://github.com/zanata/zanata/commit/251463ea39f6aad52f75e16bca048040e692a4b8
Comment 2 Ding-Yi Chen 2012-08-13 00:01:17 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120810-0025).

Not this fix does not intend to apply to 1.7 and earilier servers.
Comment 3 David Mason 2012-09-12 00:39:22 EDT
Cherry-picked above adjustment and fix to 1.7 branch.

See: https://github.com/zanata/zanata/compare/2dfccb5c17c97b549cc914ab779cd003278c5fa0...896a1f8d3246ab20ad15d3ec7a34830596bb199f
Comment 4 David Mason 2012-09-12 00:40:28 EDT
*** Bug 856423 has been marked as a duplicate of this bug. ***
Comment 5 Ding-Yi Chen 2012-09-13 00:50:22 EDT
Verified with Zanata version 1.7.3-SNAPSHOT (20120913-0015)

Note You need to log in before you can comment on or make changes to this bug.