Bug 842214 - RFE: Plural definition for locale should be found by also using '.' and '@' as separators.
RFE: Plural definition for locale should be found by also using '.' and '@' a...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic, Component-UI (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.7.2
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 02:47 EDT by Carlos Munoz
Modified: 2012-12-02 22:22 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.7.2-SNAPSHOT (20120802-0012)
Doc Type: Bug Fix
Doc Text:
Cause Plural information was not being found for some very specific locale names (for example: sr@latin). Consequence Translation for these locales did not allow for plurals because the relevant plural information could not be found. Change Support new '.' and '@' separator characters in locale names to find plural information. Result Plural information can now be more easily found for locales with names that include the '.' and '@' characters such as sr@latin.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2012-07-23 02:47:16 EDT
Description of problem:
Current release can only locate plural information for locale names of type 'es_ES'. It should allow to find plural information for locale names of type 'es@ES'. i.e. Using other separator characters than '_'.

Version-Release number of selected component (if applicable):
1.7.0
Comment 1 Carlos Munoz 2012-07-24 01:03:11 EDT
Plural information can now be found even when locale names have '.' and '@' as separator characters.

See:
http://github.com/zanata/zanata/commit/14985aab8e5f4ea609bbb592af9ca8ee9e86a6aa
Comment 2 Carlos Munoz 2012-07-24 01:03:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Plural information was not being found for some very specific locale names (for example: sr@latin).

Consequence
Translation for these locales did not allow for plurals because the relevant plural information could not be found.

Change
Support new '.' and '@' separator characters in locale names to find plural information.

Result
Plural information can now be more easily found for locales with names that include the '.' and '@' characters such as sr@latin.
Comment 3 Ding-Yi Chen 2012-08-01 23:59:57 EDT
VERIFIED with Zanata version 1.7.2-SNAPSHOT (20120802-0012)
Zanata version 1.8-SNAPSHOT (20120802-0024)

Note You need to log in before you can comment on or make changes to this bug.