Bug 842253 - Native client doesn't accept the _netdev mount option that's recommended in the Adminstration Guide
Native client doesn't accept the _netdev mount option that's recommended in t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Divya
Sudhir D
:
Depends On:
Blocks: 858430
  Show dependency treegraph
 
Reported: 2012-07-23 04:59 EDT by Patric Uebele
Modified: 2015-04-10 03:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858430 (view as bug list)
Environment:
Last Closed: 2015-04-10 03:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 204443 None None None 2012-10-16 08:26:09 EDT

  None (edit)
Description Patric Uebele 2012-07-23 04:59:28 EDT
Description of problem:
In chapter 9.1.2.2, Admin Guide states

To automatically mount a Gluster volume
• To mount a volume, edit the /etc/fstab file and add the following line:
HOSTNAME-OR-IPADDRESS:/VOLNAME MOUNTDIR glusterfs defaults,_netdev 0 0

but the option seems to be unknown to the FUSE client:

[root@client1 ~]# mount /distmnt1/
unknown option _netdev (ignored)


Version-Release number of selected component (if applicable):2.0


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Ujjwala 2012-08-28 09:55:50 EDT
Verified it in the above mentioned link and looks fine.
Comment 4 Niels de Vos 2012-10-16 04:46:27 EDT
From https://bugzilla.redhat.com/show_bug.cgi?id=858430#c3:

Please note that the _netdev option should be ignored by the GlusterFS native client (see Bug 848320, Bug 827121 and Bug 858442).

It is crucial for automated mounts on boot to have the _netdev option in /etc/fstab. Without the _netdev option in /etc/fstab the /etc/rc.d/rc.sysinit script will try to mount the volumes before starting the network, and fail.

It is correct that any mount commands do not need the _netdev option, the only requirement is to have _netdev in /etc/fstab.
Comment 6 Niels de Vos 2012-10-17 12:15:47 EDT
Thanks Divya! That looks good to me.
Comment 7 Ujjwala 2012-12-20 02:22:11 EST
Verified in the link above.

Note You need to log in before you can comment on or make changes to this bug.