Bug 842260 - Tomcat6 service start and immediate stop fails
Tomcat6 service start and immediate stop fails
Status: CLOSED DUPLICATE of bug 789288
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tomcat6 (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Knox
tomcat-qe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 05:21 EDT by Lukas Zapletal
Modified: 2015-11-01 19:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 11:11:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-07-23 05:21:48 EDT
Description of problem:

When I start tomcat6 and immediately stop it, sysvinit script is not able to stop the service reporting error. This causes issues to scripts and deployment systems like puppet which sometimes can start and immediately stop a service.

The issue is simple - tomcat6 startup script reports daemon is running, but it is still starting up. And because stopping is implementing with a simple HTTP call to a service port, it fails.


Version-Release number of selected component (if applicable):
tomcat6-6.0.24-36.el6_2.noarch

How reproducible:

Using the following script that can be used to test any RHEL service:

#!/bin/bash
function testservice() {
        echo service $1 $2
        /sbin/service $1 $2
        echo returns: $?
}
testservice tomcat6 stop
testservice tomcat6 status
testservice tomcat6 status
testservice tomcat6 start
testservice tomcat6 status
testservice tomcat6 stop
testservice tomcat6 status

It should always return zero code, while in the one step it returns 4.

Actual results:
4

Expected results:
0
Comment 3 Lukas Zapletal 2012-07-23 05:44:43 EDT
The issue was already reported: https://bugzilla.redhat.com/show_bug.cgi?id=842260
Comment 4 Lukas Zapletal 2012-07-24 11:11:53 EDT
Link in comment 3 is wrong, the correct link is: https://bugzilla.redhat.com/show_bug.cgi?id=789288

*** This bug has been marked as a duplicate of bug 789288 ***

Note You need to log in before you can comment on or make changes to this bug.