Bug 842299 - bacula-fd does not support -k option
bacula-fd does not support -k option
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Josef Ridky
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 08:17 EDT by Florian Weimer
Modified: 2016-07-26 08:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-26 08:00:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2012-07-23 08:17:35 EDT
bacula-client-5.0.0-9.el6.x86_645 does not support the -k option (run with reduced privileges) because it was not built against libcap.  Perhaps this could be changed?  It should not be enabled by default because backup scripts etc. will not run with root privileges anymore, breaking backwards compatibility.
Comment 2 RHEL Product and Program Management 2012-09-07 01:33:33 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Josef Ridky 2016-07-26 08:00:13 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

This does not make sense in newer releases at all.

Feel free to clone this bug for RHEL 7, if you need.

Note You need to log in before you can comment on or make changes to this bug.