Bug 842327 - My calibration device is not properly detected
My calibration device is not properly detected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: colord (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 09:44 EDT by fred
Modified: 2013-04-24 07:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-24 07:22:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred 2012-07-23 09:44:42 EDT
Description of problem:
Unable to calibrate my screen despite having a calibration device connected. Work on my coworker's computer (same model) with fedora 16.


Version-Release number of selected component (if applicable):
Most recent fedora 17 update.


How reproducible:
Always

Steps to Reproduce:
1. Go to Gnome control center, color section.
2. The calibrate button is greyed out.
3. Plug the calibration device.
  
Actual results:
Nothing happens, it is not possible to calibrate.

Expected results:
The calibrate button should be clickable.

Additional info:
-- dmesg
[  492.745688] usb 2-1.7: new full-speed USB device number 11 using ehci_hcd
[  492.833043] usb 2-1.7: New USB device found, idVendor=085c, idProduct=0300
[  492.833049] usb 2-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  492.833053] usb 2-1.7: Product: Datacolor Spyder3
[  492.833057] usb 2-1.7: Manufacturer: ColorVision Inc.

I can provide you with other logs, just tell me where to look :)
Thanks.
Comment 1 Richard Hughes 2012-09-09 17:06:08 EDT
What version colord?
Comment 2 fred 2012-09-12 23:43:33 EDT
It was the latest at thé tome I reporter the bug, so, if I recall, was above version 0.1.21.
Comment 3 fred 2012-10-10 11:23:53 EDT
It was the latest at the time I reported the bug, so, if I recall, was above version 0.1.21.
It still isnt properly recognized. Do you need additional information? Thank you for your help.
Comment 4 fred 2012-11-16 05:34:20 EST
The problem is still present on fedora 18, colord version 0.0.24-1.fc18.
dmesg:
[ 3899.461474] usb 2-1.8: new full-speed USB device number 10 using ehci_hcd
[ 3899.548732] usb 2-1.8: New USB device found, idVendor=085c, idProduct=0300
[ 3899.548737] usb 2-1.8: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3899.548741] usb 2-1.8: Product: Datacolor Spyder3
[ 3899.548745] usb 2-1.8: Manufacturer: ColorVision Inc.

colormgr get-sensors 
There are no supported sensors attached

colormgr get-devices
Object Path:   /org/freedesktop/ColorManager/devices/xrandr_Dell_DELL_U2410_F525M15B01FL_fred_1000
Owner:         fred
Created:       novembre 16 2012, 09:27:41 
Modified:      novembre 16 2012, 09:27:41 
Type:          display
Model:         DELL U2410
Vendor:        Dell
Serial:        F525M15B01FL
Scope:         temp
Colorspace:    rgb
Device ID:     xrandr-Dell-DELL U2410-F525M15B01FL
Metadata:      XRANDR_name=DVI-0
Object Path:   /org/freedesktop/ColorManager/devices/xrandr_Dell_DELL_E207WFP_CK6277A1873L_fred_1000
Owner:         fred
Created:       novembre 16 2012, 09:27:41 
Modified:      novembre 16 2012, 09:27:41 
Type:          display
Model:         DELL E207WFP
Vendor:        Dell
Serial:        CK6277A1873L
Scope:         temp
Colorspace:    rgb
Device ID:     xrandr-Dell-DELL E207WFP-CK6277A1873L
Metadata:      XRANDR_name=DVI-1
Comment 5 fred 2013-01-31 12:37:10 EST
I still have the same behaviour. Do you need anything to help you look into this matter?
Thanks
Comment 6 fred 2013-01-31 12:37:57 EST
I still have the same behaviour under fedora 18. Do you need anything to help you look into this matter?
Thanks
Comment 7 Richard Hughes 2013-02-01 11:37:53 EST
This is fixed in colord 0.1.26

Note You need to log in before you can comment on or make changes to this bug.