This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 842330 - Dynamic data is not syncing to slave when use-rsync-xattrs option is used in geo-rep
Dynamic data is not syncing to slave when use-rsync-xattrs option is used in ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
:
Depends On:
Blocks: 842366
  Show dependency treegraph
 
Reported: 2012-07-23 09:46 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 842366 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-07-23 09:46:50 EDT
Description of problem:If a file is created when geo-rep session is on and use-rsync-xattr is on , those file won't get synced to the slave. 


Version-Release number of selected component (if applicable):RHS-2.0.z


How reproducible:Consistently


Steps to Reproduce:
1.start a geo-rep session .
2.Turn on use-rsync-xattrs option 
3.Create some files on the master.

  
Actual results:The dynamically created files won't get synced 


Expected results:All the files which are created on the master should sync.


Additional info:
Comment 2 Vijay Bellur 2012-07-24 05:45:14 EDT
CHANGE: http://review.gluster.com/3714 (Fixes for gsyncd / geo-rep and FUSE listxattr) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 3 Vijay Bellur 2012-07-25 10:08:34 EDT
CHANGE: http://review.gluster.com/3725 (gsyncd / geo-rep: Fix sendmark() invocation for Normal Mixin) merged in master by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2012-07-30 14:18:28 EDT
CHANGE: http://review.gluster.com/3754 (geo-rep / gsycnd: restore the generic signature for sendmark_regular) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Vijaykumar Koppad 2012-07-31 01:35:44 EDT
Verified on RHS-2.0.z
Comment 6 Scott Haines 2013-09-23 18:38:35 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 7 Scott Haines 2013-09-23 18:41:26 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.