Bug 842360 - kernel-3.4.6-2.fc17 debuginfo unusable by systemtap
kernel-3.4.6-2.fc17 debuginfo unusable by systemtap
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 10:47 EDT by William Cohen
Modified: 2012-07-23 11:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 11:15:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Cohen 2012-07-23 10:47:16 EDT
Description of problem:

Attempted to run systemtap-1.8-4 testsuite using kernel-3.4.6-2.fc17 and the tests fail to run due to debuginfo problems. Seen this problem on both the x86 (64-bit) and arm machines.


Version-Release number of selected component (if applicable):

kernel-3.4.6-2.fc17.x86_64
systemtap-1.8-4.fc17.x86_64
systemtap-testsuite-1.8-4.fc17.x86_64

How reproducible:
Every time.


Steps to Reproduce:
1. have kernel-3.4.6-2, kernel-devel-3.4.6-2, kernel-debugifno-3.4.6-2, systemtap-1.8-4, and systemtap-testsuite-1.8-4 installed
2. cd /usr/share/systemtap/testsuite/
3. as root run "make installcheck"
  
Actual results:

Get the following error message


**** failed systemtap kernel-debuginfo smoke test:

semantic error: while resolving probe point: identifier 'syscall' at <input>:1:7
        source: probe syscall.open {println (argstr)}
                      ^



Expected results:

The systemtap testsuite starts running.


Additional info:

Did not see this problem with the locally build kernel-3.5.0. It appears to be a problem with the way the the 3.4.6-2 kernel is built.
Comment 1 Josh Boyer 2012-07-23 10:53:37 EDT
Did 3.4.5-2.fc17 work?  Does 3.4.6-1.fc16 work?

We haven't changed the _way_ the kernel is built in a very long time, so if something did change it would either be in one of the toolchain areas, or something in the kernel code itself.
Comment 2 William Cohen 2012-07-23 11:15:43 EDT
Operator error. Did not have the proper debuginfo rpms installed.

Note You need to log in before you can comment on or make changes to this bug.