Bug 842404 - remove ruby-gofer-0.64-1.el6.noarch.rpm from the install ISO
remove ruby-gofer-0.64-1.el6.noarch.rpm from the install ISO
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: wes hayutin
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 14:54 EDT by wes hayutin
Modified: 2012-08-24 09:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The latest Red Hat Update Infrastructure 2.1 ISO do not include ruby-gofer-0.64-1.el6.noarch.rpm.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1205 normal SHIPPED_LIVE RHUI 2.1 Enhancement Update 2012-08-24 11:52:31 EDT

  None (edit)
Description wes hayutin 2012-07-23 14:54:10 EDT
Description of problem:

ruby-gofer-0.64-1.el6.noarch.rpm is not installed via RHUI 2.1 however it exists on the ISO.  This rpm can be removed
Comment 1 wes hayutin 2012-07-26 16:19:47 EDT
I don't see ruby-gofer in any of the cloude or pulp (rhui-branch) spec files.. 
Is it possible this is getting added by a release engineering process?

Thanks
Comment 3 Jay Greguske 2012-07-26 16:34:28 EDT
It is. What packages get included on the ISO is driven by a "comps" file, a snippet of which looks like this:

    <packagelist>
      <packagereq type="default">gofer</packagereq>
      <packagereq type="default">gofer-package</packagereq>
      <packagereq type="default">grinder</packagereq>
      <packagereq type="default">httpd-2</packagereq>
      <packagereq type="default">js</packagereq>
      <packagereq type="default">libyaml</packagereq>
      <packagereq type="default">m2crypto</packagereq>
      <packagereq type="default">mongodb-server</packagereq>
      <packagereq type="default">mongodb</packagereq>
      <packagereq type="default">libmongodb</packagereq>
      <packagereq type="default">mod_wsgi</packagereq>
      <packagereq type="default">pymongo</packagereq>
      <packagereq type="default">python-BeautifulSoup</packagereq>
      <packagereq type="default">PyYAML</packagereq>
      <packagereq type="default">pulp</packagereq>
      <packagereq type="default">pulp-admin</packagereq>
      <packagereq type="default">pulp-cds</packagereq>
      <packagereq type="default">pulp-client-lib</packagereq>
      <packagereq type="default">pulp-common</packagereq>
      <packagereq type="default">pulp-consumer</packagereq>
      <packagereq type="default">pulp-selinux-server</packagereq>
      <packagereq type="default">python-bson</packagereq>
      <packagereq type="default">python-gofer</packagereq>
      <packagereq type="default">python-hashlib</packagereq>
      <packagereq type="default">python-httplib2</packagereq>
      <packagereq type="default">python-isodate</packagereq>
      <packagereq type="default">python-oauth2</packagereq>
      <packagereq type="default">python-webpy</packagereq>
      <packagereq type="default">rh-cds</packagereq>
      <packagereq type="default">rh-rhua</packagereq>
      <packagereq type="default">rh-rhua-selinux-policy</packagereq>
      <packagereq type="default">rh-rhui-tools</packagereq>
      <packagereq type="default">ruby-gofer</packagereq>
      <packagereq type="default">txt2rss</packagereq>
    </packagelist>

If you want me to remove ruby-gofer, I can omit it from this file and generate another ISO.
Comment 4 wes hayutin 2012-07-26 17:01:24 EDT
This isn't a big deal.. Next time you cut the iso for bug fixes etc.. yes please remove ruby-gofer from the comps file. 

Thanks Jay!
Comment 6 Martin Kočí 2012-08-03 07:23:49 EDT
Checked the iso: /root/RHEL-6.3-RHUI-2.1-20120801.0-Server-x86_64-DVD1.iso. ruby-gofer is not there.

Moving bug to VERIFIED.
Comment 7 Shikha 2012-08-16 05:23:01 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The latest Red Hat Update Infrastructure 2.1 ISO do not include ruby-gofer-0.64-1.el6.noarch.rpm.
Comment 9 errata-xmlrpc 2012-08-24 07:55:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.