Bug 842426 - Dracut didn't create a working initramfs
Dracut didn't create a working initramfs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 16:33 EDT by Robin Laing
Modified: 2012-09-27 05:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 05:31:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel 3.4.4.-4 initramfs (17.17 MB, application/octet-stream)
2012-07-23 16:33 EDT, Robin Laing
no flags Details
Working initramfs (17.12 MB, application/octet-stream)
2012-07-23 16:48 EDT, Robin Laing
no flags Details
dracut log for 3.4.2-1 kernel (99.71 KB, application/octet-stream)
2012-07-23 16:52 EDT, Robin Laing
no flags Details
dracut log for 3.4.4-4 kernel (95.99 KB, application/octet-stream)
2012-07-23 16:53 EDT, Robin Laing
no flags Details
dmesg for kernel 3.4.4-4 (244.75 KB, application/octet-stream)
2012-07-30 02:14 EDT, Robin Laing
no flags Details
init.log for kernel 3.4.4-4 (208.77 KB, application/x-troff-man)
2012-07-30 02:15 EDT, Robin Laing
no flags Details
dmesg for kernel 3.4.6-1 (244.76 KB, application/octet-stream)
2012-07-30 02:16 EDT, Robin Laing
no flags Details
init.log for kernel 3.4.6-1 (208.77 KB, application/x-troff-man)
2012-07-30 02:17 EDT, Robin Laing
no flags Details
init.log for kernel 3.4.2-1 (39.67 KB, text/x-log)
2012-07-30 02:19 EDT, Robin Laing
no flags Details
dmesg for kernel 3.4.2-1 (166.35 KB, application/octet-stream)
2012-07-30 02:23 EDT, Robin Laing
no flags Details
crypttab file (371 bytes, application/octet-stream)
2012-07-30 19:07 EDT, Robin Laing
no flags Details

  None (edit)
Description Robin Laing 2012-07-23 16:33:05 EDT
Created attachment 599856 [details]
kernel 3.4.4.-4 initramfs

Description of problem:
New kernel won't boot.  Drops to dracut shell.  No encrypted partitions are accessible.  Could be udev in dracut process not waiting for cryptsetup.

Version-Release number of selected component (if applicable):
racut-018-55.git20120606.fc16.noarch
kernel-3.3.8-1.fc16.x86_64
kernel-3.4.2-1.fc16.x86_64
kernel-3.4.4-4.fc16.x86_64


How reproducible:
System won't boot with kernel-3.4.4.4-4 at any time.  No encrypted partitions are listed in /dev/mapper/ when dropped to shell.


Steps to Reproduce:
1.  yum update to latest.
2.  Try to reboot with latests kernel and dracut.
3.  Try to follow dracut troubleshooting procedures.
  
Actual results:
Get dropped to dracut shell with error message.  
  "dracut warning:  Unable to process initqueue"


Expected results:
System to boot as normal.

Additional info:
I tried some testing late last night/early this morning and got to the point that udev isn't finding the partitions.  udev sender uid=-1, message ignored.

Tried to follow the various troubleshooting documents but they refer to grub.conf and not grub2.  Tried to enable dracut debugging but couldn't get it to work.

This is similar to bug https://bugzilla.redhat.com/show_bug.cgi?id=839362.
Comment 1 Robin Laing 2012-07-23 16:48:32 EDT
Created attachment 599857 [details]
Working initramfs

This is the working initramfs
Comment 2 Robin Laing 2012-07-23 16:52:34 EDT
Created attachment 599859 [details]
dracut log for 3.4.2-1 kernel

This is the dracut log file for the working kernel.
Comment 3 Robin Laing 2012-07-23 16:53:29 EDT
Created attachment 599860 [details]
dracut log for 3.4.4-4 kernel

This is the dracut log for the non-working kernel.
Comment 4 Robin Laing 2012-07-23 16:54:35 EDT
Looking through the working and non-working initramfs, I see that in the working one it points to modules with 

run/initramfs/lib/modules/3.4.2-1.fc16.x86_64/kernel/crypto/md4.ko

whereas the broken one points to the modules like this.

lib/modules/3.4.4-4.fc16.x86_64/kernel/crypto/md4.ko


On another computer, I didn't update the dracut and it is till running dracut-013-22.fc16.noarch but works with 3.4.4-4.fc16.i686.PAE.

I personally don't know enough to go further and the troubleshooting pages don't work with grub2.

From yum.log

Jul 01 02:41:32 Installed: kernel-3.4.2-1.fc16.x86_64
Jul 09 01:51:32 Installed: kernel-3.4.4-4.fc16.x86_64

Apr 07 10:18:54 Updated: dracut-013-22.fc16.noarch
Jul 05 16:12:36 Updated: dracut-018-55.git20120606.fc16.noarch
Comment 5 Harald Hoyer 2012-07-24 06:04:56 EDT
Sorry for the inconvenience.

Can you boot with "rd.debug" on the kernel command line, and after you are dropped to the dracut debug shell, save "/run/initramfs/init.log" and the output of "dmesg" to a USB stick or the /boot partition.

Then boot the old kernel and attach these files here.
Comment 6 Robin Laing 2012-07-30 01:22:30 EDT
I applied the latest kernel upgrade and still get dropped to the same error messages.  I can only boot into the 4.2-1 kernel.

kernel-3.4.2-1.fc16.x86_64
kernel-3.4.6-1.fc16.x86_64
kernel-3.4.4-4.fc16.x86_64

I am not sure about the "kernel command line" but I will see what I can find and report for both kernels.
Comment 7 Robin Laing 2012-07-30 02:14:24 EDT
Created attachment 601112 [details]
dmesg for kernel 3.4.4-4

This is the dmesg for kernel 3.4.4-4
Comment 8 Robin Laing 2012-07-30 02:15:33 EDT
Created attachment 601113 [details]
init.log for kernel 3.4.4-4

/run/initramfs/init.log for kernel 3.4.4-4
Comment 9 Robin Laing 2012-07-30 02:16:39 EDT
Created attachment 601114 [details]
dmesg for kernel 3.4.6-1

dmesg for kernel 3.4.6-1, just updated.
Comment 10 Robin Laing 2012-07-30 02:17:52 EDT
Created attachment 601115 [details]
init.log for kernel 3.4.6-1

/run/initramfs/init.log for kernel 3.4.6-1
Comment 11 Robin Laing 2012-07-30 02:19:22 EDT
Created attachment 601118 [details]
init.log for kernel 3.4.2-1

/run/initramfs/init.log for kernel 3.4.2-1.  This is a working boot.
Comment 12 Robin Laing 2012-07-30 02:23:37 EDT
Created attachment 601120 [details]
dmesg for kernel 3.4.2-1

dmesg for working boot.  Kernel 3.4.2-1
Comment 13 Robin Laing 2012-07-30 02:29:46 EDT
Okay, I finally figured out how to configure grub2.  This needs to be in a simple instruction someplace.

  edit "/etc/default/grub" to remove quite and rghb as well as add rd.debug
  run grub2-mkconfig -o /boot/grub2/grub.cfg


I have uploaded both non-working init.log and dmesg for the failed boots as well as the working files.
Comment 14 Harald Hoyer 2012-07-30 07:52:30 EDT
Is your /etc/crypttab setup correctly? What is your kernel command line?

Please attach /etc/crypttab

Dracut does not seem to find "rd.luks.uuid=luks-5bc868a4-39fb-4fe6-97cb-4979217fa9f9".
Comment 15 Robin Laing 2012-07-30 19:07:00 EDT
Created attachment 601354 [details]
crypttab file

I have uploaded the cryptab file.  This file format has worked with kernels upto the current ones.
Comment 16 Harald Hoyer 2012-07-31 05:20:16 EDT
ah...

luks-5bc868a4-39fb-4fe6-97cb-4979217fa9f9 UUID=5bc868a4-39fb-4fe6-97cb-4979217fa9f9 /dev/urandom swap

You can remove that safely from the kernel command line for now. The real root should set it up for you later.
Comment 17 Robin Laing 2012-08-02 01:30:44 EDT
I am not sure what you mean.  Do you mean to remove 
  "rd.luks.uuid=luks-5bc868a4-39fb-4fe6-97cb-4979217fa9f9"
from the command line in /etc/default/grub or remove 
  "luks-5bc868a4-39fb-4fe6-97cb-4979217fa9f9 UUID=5bc868a4-39fb-4fe6-97cb-4979217fa9f9 /dev/urandom swap"
from the crypttab?

And what do you mean by the "real root" should set it up later?  Is this the actual "/" partition on the disk and when it is mounted?

Can I run "dracut initramfs-3.4.6-1.fc16.x86_64.img 3.4.6-1.fc16.x86_64" to create a new initramfs after making the changes to test the changes?
Comment 18 Harald Hoyer 2012-08-02 06:46:18 EDT
(In reply to comment #17)
> I am not sure what you mean.  Do you mean to remove 
>   "rd.luks.uuid=luks-5bc868a4-39fb-4fe6-97cb-4979217fa9f9"
> from the command line in /etc/default/grub

yes, and of course in /etc/grub2.cfg or /etc/grub.conf.

No need to recreate the initramfs and no need to run "grub2-mkconfig -o /boot/grub2/grub.cfg"
Comment 19 Robin Laing 2012-08-10 00:13:09 EDT
This worked.  I wonder how this came about and when in the process it started as I never edited these files before.

I guess this means the bug can be closed unless this is an issue for others.

Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.