Bug 842480 - postfix assertion error
postfix assertion error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 21:09 EDT by Ian Mortimer
Modified: 2012-10-08 18:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-08 18:06:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2012-07-23 21:09:11 EDT
Description of problem:
With a working postfix configuration, including the default, `service postfix status' returns error code 134, causing puppet to restart postfix on every run.


Version-Release number of selected component (if applicable):
postfix-2.9.3-1.fc17.x86_64


How reproducible:
Always with any working configuration

Steps to Reproduce:
1.install fedora 17 with postfix
2.start postfix
3.run: service postfix status
  
Actual results:
returns error code 134 with this message:

postfix/postfix-script[27929]
Assertion 'new_length >= 3' failed at src/shared/util.c:3724, function ellipsize_mem(). Aborting.
postfix/master[27930]Aborted


Expected results:
Should return 0, since postfix is running and working correctly


Additional info:
This doesn't affect functionality but causes puppet to restart postfix on every run (every 1/2 hour in the default puppet configuration).


--
Ian
Comment 1 Ian Mortimer 2012-10-08 18:06:10 EDT
This is fixed by a systemd update in Fedora 18 so can be closed.

Note You need to log in before you can comment on or make changes to this bug.