Bug 842494 - Config custom file wizard should not pop up if user has config file specified when default config file doesn't exist.
Config custom file wizard should not pop up if user has config file specified...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
John (J5) Palmieri
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-23 23:12 EDT by joycezhang
Modified: 2015-05-14 22:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joycezhang 2012-07-23 23:12:05 EDT
Description of problem:
Config file wizard is shown even if user has config file specified when the default config file doesn't exist.

Please refer to followning message:

# rhc app status -a php5 --config /root/openshift.conf 

Starting Interactive Setup for OpenShift's command line interface

It looks like you have not configured or used OpenShift client tools on this computer. We'll help you configure the client tools with a few quick questions. You can skip this in the future by copying your configuration files to other machines you use to manage your OpenShift account:

/root/.openshift/express.conf
/root/.ssh/

To connect to stg.openshift.redhat.com enter your OpenShift login (email or Red Hat login id): jinzhang+5@redhat.com
Password: ******

Created local config file: /root/.openshift/express.conf
The express.conf file contains user configuration, and can be transferred to different computers.

We will now check to see if you have the necessary client tools installed.

Checking for git ... found

Checking for your namespace ... found namespace:
    jin5

Checking for applications ... found
    * php5 - http://php5-jin5.stg.rhcloud.com/

The OpenShift client tools have been configured on your computer.  You can run this setup wizard at any time by using the command 'rhc setup' We will now execute your original command (rhc app status -a php5 --config /root/openshift.conf)

Password: ******


RESULT:
6ef3013ecd5e446db754651943fafd95
6ef3013ecd5e446db754651943fafd95
Total Accesses: 3
Total kBytes: 0
Uptime: 348
ReqPerSec: .00862069
BytesPerSec: 0
BytesPerReq: 0
BusyWorkers: 1
IdleWorkers: 0
Scoreboard: W....


Version-Release number of selected component (if applicable):
stg.openshift.redhat.com
rhc-0.96.3
Fedora 17 

How reproducible:
always

Steps to Reproduce:
1. Remove config file from ~/.openshift/express.conf
2. Run command: rhc app status -a php5 --config /root/openshift.conf 

  
Actual results:
Config file wizard is shown to create config file and the specifed config file is not be used.


Expected results:
The specified config file should be used and no config file wizard pops up.


Additional info:
1. If run rhc setup --config /root/openshift.conf, it works fine.
2. The specified config will be used if the default config file exists.
Comment 1 Clayton Coleman 2012-10-17 14:52:42 EDT
Can you retry using the latest commands (the new ones?)
Comment 2 joycezhang 2012-10-17 22:38:55 EDT
Recheck with latest rhc-0.99.7.gem client, it works fine with latest command. Please check as below:

# rhc app show php1 --state --config ./openshift.conf
Password: *


RESULT:
Geargroup php-5.3 is started

So move it to ON_QA
Comment 3 joycezhang 2012-10-17 22:40:03 EDT
Mark it as Verified as it works well with latest command on new client rhc-0.99.7.gem. Thanks.

Note You need to log in before you can comment on or make changes to this bug.