Bug 842503 - [virtio-win][netkvm]Multiple parallel netperf clients will have windows2008 guest with rhel 6 driver installed frozen on rhel5 host
[virtio-win][netkvm]Multiple parallel netperf clients will have windows2008 g...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virtio-win (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: rc
: 5.9
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-24 00:37 EDT by Min Deng
Modified: 2013-03-27 09:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-27 09:36:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-07-24 00:37:04 EDT
Description of problem:
Multiple parallel netperf clients will have windows2008 guest with rhel 6 driver installed froze on rhel5 host,User even can not reset guest from monitor.

Version-Release number of selected component (if applicable):
virtio-win-1.5.3-1.el6_3.noarch.rpm
How reproducible:
Always,
Steps to Reproduce:
1.boot up guest with the CLI -
/usr/libexec/qemu-kvm -m 4G -smp 4 -usbdevice tablet -drive file=/home/win2k8-64-iso.qcow2,if=virtio,boot=on,werror=stop,cache=writeback,format=qcow2,media=disk -net nic,model=virtio,vlan=0,mac=00:22:66:c3:36:31 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -boot dc -monitor stdio -vnc :11 -fda /usr/share/virtio-win/virtio-drivers.vfd -drive file=/usr/share/virtio-win/virtio-win-1.0.3-52454.iso,if=ide,index=2,media=cdrom -drive file=/home/en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=ide,index=1,media=cdrom -drive file=/home/disk1.raw,if=virtio,werror=stop,cache=writethrough,readonly=on,format=raw,media=disk,serial=mimimi -drive file=/home/disk2.raw,if=virtio,werror=stop,cache=writeback,format=raw,media=disk,serial=hhhh,readonly=on -M rhel5.6.0
2.setup a netserver 2.4.5 outside host,install driver,cygwin and executed the scripts as followings in guest.
ERVER_IP=10.66.85.230
      for proto in TCP_STREAM UDP_STREAM    
      do
        for sz in 32 64 128 256 512 1024 2048 4096 8192 16384 32768
          do
            netperf -H $SERVER_IP -c -C -t $proto -f m -l 180s -- -m $sz
          done
       done

Actual results:
The guest seemed stop.Neither guest nor monitor can be reached.User even cannot execute system_reset from monitor.
Expected results:
Though the guest underwent large pressure it should finish but not stop.

Additional info:
********************************************
Not reproduced - rhel5 host + rhel5  driver
Not reproduced - rhel6 host + rhel6 driver
Reproduced   -   rhel5 host + rhel6 driver
********************************************
Comment 3 Yan Vugenfirer 2012-07-24 06:00:35 EDT
1. Is there vhost on the host? Please try to run without.

2. Please disable "Init.UsePublishEvents" parameter from device manager -> advanced tab
Comment 4 Mike Cao 2012-07-24 06:11:12 EDT
(In reply to comment #3)
> 1. Is there vhost on the host? Please try to run without.
RHEL5 host does not support vhost
> 
> 2. Please disable "Init.UsePublishEvents" parameter from device manager ->
> advanced tab
Comment 6 Min Deng 2012-08-01 04:35:07 EDT
(In reply to comment #3)
> 1. Is there vhost on the host? Please try to run without.
> 
> 2. Please disable "Init.UsePublishEvents" parameter from device manager ->
> advanced tab

   I followed your advice to disable the "Init.UsePublishEvents" parameter and retest bz.The issue still was reproduced.
Thanks
Min
Comment 7 Yan Vugenfirer 2012-08-07 04:09:23 EDT
Please provide QEMU version that was used during testing.

Thanks!
Comment 10 Ronen Hod 2012-08-08 09:20:08 EDT
Since we decided not to use RHEL6 virtio-win drivers in RHEL5, moving to 5.10.
Comment 18 RHEL Product and Program Management 2013-03-27 09:36:02 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.